Unavailable entities - delete?

I have a list of entities I wish to delete but are unable to find a way of deleting them.

Ive tried the Configuration > Entities and searched for one of them but can’t delete from there.

When this has happened before, I’ve searched using Visual Studio Code and deleted the entry that way, but this time these entities are not showing up anywhere in VSC to be deleted.

Any ideas please.

How were those entities added? Via some integration? via yaml?

By an integration, probable Tasmota

You will likely have to delete the device provided by that integration.

So if I go to configuration>entities I can then tap status and it will sort by status and I can check the unavailable ones and bulk delete…

Or did I misunderstand you?

1 Like

Ive tried that Dave

It won’t let me select the last 3 at all.

Then this after pressing Remove selection

As I said above after trying this in the passed, if it fails, I search the entity in VSC and find it somewhere in a file in the .storage folder and delete the section of code containing the entity, but in the case these don’t show up in VSC after a search, so I have no idea where they are hiding.

That was my thought, but didn’t want to go down that road as I have other devices that will all need re-entering

You should be able to just delete the associated device that is unavailable without deleting any of the others from that integration.

Check on the devices page for that device.

Will look into it, thanks guys for your help

You can most likely disable the entity on the device page as well…

Probable, Ive not tried that, because of my OCD I wanted to get rid of them :joy:

I get the OCD but if a device provides entities you don’t want the only option you have is to disable them. Tasmota does this as well as lots of integrations.

If they were added from an Integration and you have removed them from the integration eg Sonoff, Xiaomi but they still appear in HA a reboot of Home Assistant will usually make them disappear.

back to this…]]entities was created when I added them into my configuration.yaml, which then lead HA to create the associated entity, I have removed allot of these previous mqtt sources/entities, but still have them listed under (*new interface/developer tools/states\0

how can clean out.

1 Like

If they were created as part of a YAML, I’ve found that you actually need to reboot TWICE to get them to really disappear after removing them from the YAML. But this still doesn’t seem to delete history data in the database, so if you recreate sensors/entities with the same name, the old data will still be there. I have not found a good way to delete that.

I added some Zigbee lights and I gave them the name backlight1 … backlight4. The actual Entities were named light.backlight1_forceonlight etc.
I lived with it overnight but when I started making sure Alexa and Google could see them I decided to change the Entitiy name to light.backlight1 etc.
So now I have the 4 entities as I want them and have created groups and stuff and they are in Alexa and Google OK.
But, I now also have 4 unavailable entities with the original names. I cannot work out how to delete them. I probably have lots of others like it too.

I have the exact same problem. I want to delete the unused entities. It is more than OCD; When I create a new entity, it appends _2, _3 etc… to the desired entity name, which requires correcting all the automations. Any new developments since the last post?



I have 2 EVE Energy and 1 EVE Door/Window which I had integrated thru Matter. Initially this worked fine but somewhere along the line they became UNAVAILABLE. I have reloaded the Matter Integration, Restarted HA, rebooted the whole system (HA Yellow), nothing helped.
HA does not allow to delete Entities which are unavailable. I have also deleted the Matter Integration (+ restart; + reboot) in the hope the rogue entities would disappear.
Unfortunately this did not help either, the devices/entities are still listed and unavailable.

I would appreciate guidance as t how to get rid of these.

Many thanks in advance!

Same issue here (Eve Energy became unavailable and now it’s stuck), just bumping the thread in hopes that a savior comes along.


Dito, I also have an entity I tried to delete (manually from .storage folder). Still appears again. It is not coming from a device and it can’t be deleted from the UI.