Unifi AP inside unifi controller stays in adopting

Im using unifi controller as addon for hass.io on my pi3
The controller works
Everything works (even pihole)
however all devices (usg, switch and 1 AP) are working , except my 2nd acces point
It stays in adopting
Dont know why. Even reset wont help.
I ask here, cause maybe its a port issue

If you read https://help.ubnt.com/hc/en-us/articles/204950304

you see the most commoon fault whens adopting fails

I hope someone here can help

i got hassio and 2 addons (pihole and unifi controller)

Thanks in advance

I have had this happen when my controller was advertising itself as a hostname, and the AP couldn’t resolve that hostname. I switched my advertisement to be an IP and I manually set the inform URL in the AP via SSH.

1 Like

This sounds like somthing.
Could you explain more pls.
Where do i switch that advertisement?
and do i set the inform url?, i know how to ssh

Scroll down to the SSH section


mm its empty with me

gratis foto uploaden voor forum

Should i fill in?

1 Like

Your AP doesn’t know where your controller is if you don’t have anything there.

See the Network Discovery piece?

i just typed in the ip under “controller hostname/IP” and checked the option “override inform host with controller hostname/IP”

and now the AP is provisioning, i hope it works !!
fingers crossed.

Strange cause i never did that in earlier setups


I think the default for the AP is http://unifi:8080 but if your system is not broadcasting its name as unifi, it won’t work.

1 Like

Thank you mate !
Setting the ip in the controller then click the override thing, made it work !!!
Thank you a lot !
I didnt need to set the inform url in the ap via ssh

just filled in ipadres of controller and tick to override inform host with controller hostname/ip

Thanks ! Solved !

1 Like

Just in case anyone else stumbles on this problem, you can get the SSH credentials for existing devices on your network from a previously working controller from the SSH Authentication settings vai the Controller’s Web UI. If you are using Hassio you may have had to set the regular port to something other than 8080 (which was the case for me as it conflicted with something else), in which case you would need to manually re-associated your devices using one of the methods in the article above.

Thanks! That solved it for me too!!!

Thank you, thank you, thank you, thank you!!!

Same here, thanks for the tip, you saved me.

I love you friend, thanks so much

Just created an account to thank you! This was the sollution.

Just went through this issue myself and a lot of the guidance is correct but the pages have changed in the UI. So now go to SETTINGS>>SYSTEM>>ADVANCED and add the HA IP to the INFORM HOST field



Thanks for the up to date information

1 Like

Thanks for sharing - I had the same issue and that resolved the issue! Thanks! :slight_smile:


That fixed it with my local dnsname. Thanks.