Unifi Camers RTSP alexa integration says "Doesnt Support That"

As stated above, I have 5 cameras all tied into HA, just updated to 108 and alexa sees the cameras and shows they are cameras but when I tell my echo show 5 to show garage, or show back porch, it says “Garage Doesnt Support That”. Anyone else having issues with it?

I’m seeing this same issue with my Hikvision cameras so i’d guess it’s not unifi related but I’d like to find a solution too! The logs mention that Alexa requires the camera stream to be HTTPS, but as far as I know the “stream” integration does this for us.

Yeah I worked with the dev to get some more documentation up about it. Apparently it should work if you use the cloud service (which I do but still isnt working).

I figured out the issue with mine. Because I use a reverse proxy to access home assistant on port 443, I don’t specify the web URL in the config or bother having HA run https (ssl) itself, the proxy handles it all. This seems to confuse the alexa streaming integration and cause the error in the logs. You need your domain name in the configuration.yaml file, even though in theory this all proxies though the HA cloud so amazon shouldn’t care what port you operate HA on or even if it’s open to the web.

Could you elaborate on the configuration you did? I have both internal and external URL set to https://fqdn:443 in the UI. Do I need to put something in configuration.yaml as well?

I’m running Apache2 as reverse proxy with Let’s Encrypt SSL.

Actually - I got it! Not sure what I did, specifically.

Set the https:// external URL in the UI for both internal / external URL. Configured the camera to “preload stream”. Restarted HA and asked Alexa to discover my devices (it said no new devices found), but now it works.