Unifi Controller add-on out of memory

I installed my Unifi controller as a hassio add-on a couple of weeks ago.

I started getting emails from my controller yesterday saying that my controller is almost out of data space.

is there anything I can do in the add-on or in the controller to fix this?

What are your data retain settings?

I had to lower the 5 minute retain on my Cloud Key Gen 1.


from this I think I don’t have that running:


Ok, that’s not your problem then.

EDIT: What about backups?

only one week worth (daily backup) so only 7 backups total

I’m out of ideas then. Can you open a terminal in the container?


As futher info I just looked at the add-on storage in the hassio directory and there are a bunch of “repair” files in there so I’m not sure if that’s where the extra data is located. The regular db files add up to 288mb. So having all of those with a couple of hundred mb each could eat up the device storage.

Do you think it’s safe to delete those?

I don’t know. Maybe ask on the Ubiqiti Community Forums.

Well, I made a command decision and just deleted all of those tmp folders and restarted the container.

so far so good.

I’ll have to see if that stops the container from complaining about being out of storage.

that seems to have solved my out of storage space issue but…


You said you use the gen 1 cloud key…

does that work well for you?

I’ve tried installing the controller software thru docker in three different ways so far - two different installs on my nuc (that runs non-hassio HA) using two completely different “popular” images and one using a spare RPi I installed hassio onto just so I could run the Unifi controller add-on - and none of those install methods are very stable.

I’m still using only the hassio add-on version but it locks up constantly and I have to restart the container to get it to run. The other two on the NUC did the same thing which is why I tried as many different methods as I did just to try to get one to work for me.

And for some reason my unifi device tracker doesn’t track my android phone at all or my wifes iPhone only intermittently. All of my devices (50+) showed up in the entity registry auto-discovered but after that it seems like there is no comms at all for my phone.

My network stability is way better with my unifi gear but the device trackers not working and the controller software constantly locking up is very frustrating.

So…I’m wondering if it would be worth the money to buy a 1st gen cloud key (since it’s cheaper than the new ones)?

The only issue I’ve had is with firmware updates. The last update caused the CK to become unresponsive and I had to factory reset, update and restore a backup. I see people complaining about this happening for the currently available update too. Prior to the last update, all updates proceeded without issue.

No stability issues at all. I’m monitoring 4 APs and 1 switch.

I don’t use the HA unify tracker, so not sure how well that works.

1 Like

where is the logs file for Unifi ? I can’t seem to find it. i don’t seem to find it at the above location " /usr/share/hassio/addons/data/a0d7b954_unifi/unifi/data/db$ ". Neither e few levels back within this path…
Is it stored somewhere else? I have a feeling my logs file is massive and needs cleaning up.