Unifi device tracker site_id issues

I am having issues with the Unifi device tracker site_id parameter. I can get unifi device tracker working correctly if i configure my site name in the controller for default, which is the default for site_id if none is specified.

If I enter the site name site_id: Max House
Home Assistant shows “Failed to scan clients: api.err.NoSiteContext” in the log. I think I am missing something simple but not sure what. I have tried “Max House” ‘Max House’ “site_id: Max House” all with no luck.

Any help would be greatly appreciated.

The source seems to indicate you need to restart hass after changing site_id

Did you find a solution for this?
I am having the exact same issue.

Were you able to resolve this?
I have the same issue and it is driving me nuts!!!


Currently having the same issue

Was having the same issue and was able to figure it out today. You need to grab the Site ID from the URL that you use to manage the controller. https://xxx.xxx.xxx.xxx:8443/manage/site//settings/etc…


Thanks so much! This is one of those little quirks that once you know is so simple. I might need to go put a pull request in the docs. Because it it not obvious at all from first glance.

Just wanted to say thanks for pointing this out - I was pulling my hair out trying to get it to work. I was using the Side ID name - not the unique string.

Thank you @rob.riley. That is not documented as far as I could see, and not intuitive to me. After a change to the site id from the url my setup is back up and working. Many thanks.