Home Assistant Community

Unifi Devices Showing Home, constantly


Running HASSIO .87 and Unifi 5.9.29. Everything has been working fine for months until today. I noticed my unifi device trackers weren’t updating to not_home. When I logged into my unifi controller it was asking me to set up new or restore from backup. We had a few power outages over the weekend so maybe something got messed up with all the off and on power. I restored a backup from last week without issue.

The device trackers are still reporting home. None of the devices I’m tracking are connected to wifi and the unifi controller also shows this. None are connected in unifi. I tried manually changing the status to not_home but they just change right back to home. Also tried restarting HA but it’s still the same.

Any ideas on what’s happening or how to fix it?


In case anyone has this same issue, this is what resolved it for me. Kind of.

I found that once the device reconnected to the wifi, then disconnected the status would track properly in HA. I had one device that was gone for a week and therefore showed as “home” for the entire time. Restart of HA or Unifi would not change it. Once it reconnected to wifi it started tracking again.

Weird but it’s working now.