Unifi Protect default camera sensor name

The Unifi Protect integration adds a sensor “High” for all camera devices. This appears to be referring to the first camera sensor on the device, since the G4 Doorbell Pro now has 2 cameras; a main high-mounted and a second low-mounted package camera.

This sensor is poorly named, and for devices with only one camera it’s unnecessary to default to calling it high. It’s not intuitive what “high” refers to when the device only has a single camera in it. I suggest the naming be reverted to however it was before the introduction of the G4 Doorbell Pro, and then add different naming as necessary specifically for the device with two camera sensors.

Open to alternative suggestions but want to start a discussion on how to better clarify the naming of the camera sensor.

High refers to the high resolution feed. If you enable all 3 in Protect, you will get low, medium and high cameras. I think they are disabled by default in HA

The camera entity is actually named {camera name} High or more accurately, {camera name} {channel name}. It is just that Home Assistant automatically collapses the name if the prefix of the entity matches the device name. The names match up the names of the camera channels in UniFi Protect. And yeah, as @Holdestmade pointed out, all of them are disabled by default except the highest quality enabled one. Insecure means it is using the RTSP URL instead of the RTSPS URL, which is no longer exposed in the UI.

The Package Camera just acts as a 4th camera channel for the Doorbell Pro. All other cameras only have 3 channels (High/Medium/Low).

image

image

I appreciate the response from both of you. I definitely seem to have misinterpreted things.

What I find strange though is I am not using RTSP. I only ever view the cameras (up until now) from Protect, so I had no need to enable streaming to 3rd party apps. Double checking the camera configuration within Protect, I confirmed RTSP is disabled (which is default when you set up a new camera.) When I installed the Protect integration, it picked up the camera devices and correctly show the camera feed entity and labeled it High. And when adding the doorbell card to lovelace, it correctly streams the camera. I have to assume it’s getting the stream directly from Protect on the UDMP and not from RTSP via the camera directly.

If you do not have any of the RTSP feeds enabled, it still gives you one for the high, but you cannot get actual live streaming. You essentially only get snapshots. It would be like 1 FPS if you tried to stream it.

Thank you, this was a great explanation. And you’re exactly right, when I view the stream from the Lovelace dashboard it is about a 1FPS slideshow. You don’t notice when it’s just the timestamp ticking away but as soon as a tree starts to move or someone walks in front of the camera its immediately obvious it’s not a real-time stream.

I still think the name given to the RTSP stream could be more descriptive, but it’s not like I have any better suggestions for what to call it. At least the behavior and naming makes more sense now. Thank you everyone for taking the time.