UniFi Protect stopped displaying cameras on Google Hub

I have automation to display UniFi Protect camera on Google Hub. It stopped working about a week ago, after working fine for the last few years. Now whe there is a trigger, Google Hub goes into a buffering state [i.e. black screen of playing media] and never exists. I checked the logs and there are no errors, I tried the different camera and different Google hub, same result. I can see cameras on the dashboard without an issue.

Does anyone else have this issue? Any recommendations on how to fix it?

I’ve seen issues with UniFi camera feeds on the dashboard not appearing and requiring a refresh, but you need to consider how Chromecast works.

The server passes a URL to the cast device. The cast will only work if the URL is accessible (network naming, DNS, IPv6 can all be issues), and the server allows it (access control).

I’ve never worked out the YAML to get a cast to work (would be interested in how!), but a test using the Media browser to manually case the Unifi camera source just worked fine to a Hub Max and a docked Pixel tablet.