Universal Powerline Bus (UPB) Setup help

I am trying to install the Universal Powerline Bus (UPB) integration and no matter how I enter the file name and location I am getting the error “Missing or invalid UPB UPStart export file, check the name and path of the file.”.

I placed the .upe file in the config directory.

I have tried to enter the path and file name many different ways but nothing seems to work.

Any help would be greatly appreciated!

This tell you anything? Jump link to the debugger enable.
Universal Powerline Bus (UPB) - Home Assistant.

Here is what is in home-assistant.log in the config directory:

2024-06-23 12:05:56.859 ERROR (MainThread) [upb_lib.parse_upstart] Cannot open UPStart file: [Errno 2] No such file or directory: ‘/root/config/upstart.upe root/config/upstart.upe’
2024-06-23 12:05:56.859 ERROR (MainThread) [homeassistant.components.upb.config_flow] Missing or invalid UPB file: /root/config/upstart.upe root/config/upstart.upe
2024-06-23 12:06:53.190 INFO (MainThread) [upb_lib.upb] Using flags: {‘’: True}
2024-06-23 12:06:53.199 WARNING (MainThread) [homeassistant.util.loop] Detected blocking call to open inside the event loop by integration ‘upb’ at homeassistant/components/upb/config_flow.py, line 41: upb = upb_lib.UpbPim({“url”: url, “UPStartExportFile”: file_path}) (offender: /usr/local/lib/python3.12/site-packages/upb_lib/parse_upstart.py, line 18: with open(filename) as file_handle:), please create a bug report at Issues · home-assistant/core · GitHub
Traceback (most recent call last):
File “”, line 198, in _run_module_as_main
File “”, line 88, in _run_code
File “/usr/src/homeassistant/homeassistant/main.py”, line 223, in
File “/usr/src/homeassistant/homeassistant/main.py”, line 209, in main
exit_code = runner.run(runtime_conf)
File “/usr/src/homeassistant/homeassistant/runner.py”, line 190, in run
return loop.run_until_complete(setup_and_run_hass(runtime_config))
File “/usr/local/lib/python3.12/asyncio/base_events.py”, line 672, in run_until_complete
File “/usr/local/lib/python3.12/asyncio/base_events.py”, line 639, in run_forever
File “/usr/local/lib/python3.12/asyncio/base_events.py”, line 1988, in _run_once
File “/usr/local/lib/python3.12/asyncio/events.py”, line 88, in _run
self._context.run(self._callback, *self._args)
File “/usr/local/lib/python3.12/site-packages/aiohttp/web_protocol.py”, line 452, in _handle_request
resp = await request_handler(request)
File “/usr/local/lib/python3.12/site-packages/aiohttp/web_app.py”, line 543, in _handle
resp = await handler(request)
File “/usr/local/lib/python3.12/site-packages/aiohttp/web_middlewares.py”, line 114, in impl
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/security_filter.py”, line 92, in security_filter_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/forwarded.py”, line 83, in forwarded_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/request_context.py”, line 26, in request_context_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/ban.py”, line 85, in ban_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/auth.py”, line 242, in auth_middleware
return await handler(request)
File “/usr/src/homeassistant/homeassistant/components/http/headers.py”, line 32, in headers_middleware
response = await handler(request)
File “/usr/src/homeassistant/homeassistant/helpers/http.py”, line 73, in handle
result = await handler(request, **request.match_info)
File “/usr/src/homeassistant/homeassistant/components/http/decorators.py”, line 81, in with_admin
return await func(self, request, *args, **kwargs)
File “/usr/src/homeassistant/homeassistant/components/config/config_entries.py”, line 222, in post
return await super().post(request, flow_id)
File “/usr/src/homeassistant/homeassistant/components/http/data_validator.py”, line 70, in wrapper
return await method(view, request, data, *args, **kwargs)
File “/usr/src/homeassistant/homeassistant/helpers/data_entry_flow.py”, line 122, in post
result = await self._flow_mgr.async_configure(flow_id, data)
File “/usr/src/homeassistant/homeassistant/data_entry_flow.py”, line 368, in async_configure
result = await self._async_configure(flow_id, user_input)
File “/usr/src/homeassistant/homeassistant/data_entry_flow.py”, line 414, in _async_configure
result = await self._async_handle_step(
File “/usr/src/homeassistant/homeassistant/data_entry_flow.py”, line 517, in _async_handle_step
result: _FlowResultT = await getattr(flow, method)(user_input)
File “/usr/src/homeassistant/homeassistant/components/upb/config_flow.py”, line 91, in async_step_user
network_id, info = await _validate_input(user_input)
File “/usr/src/homeassistant/homeassistant/components/upb/config_flow.py”, line 41, in _validate_input
upb = upb_lib.UpbPim({“url”: url, “UPStartExportFile”: file_path})

When I look at the file path in file editor, the path is: /homeassistant/upstart.upe
When I look at the file path in the terminal, the path is: /root/config/upstart.upe

What should I put for the path and filename in the setup of the Universal Powerline Bus (UPB) integration?

No matter what I put, I receive the error “Missing or invalid UPStart export file, check the name of the file.”

home-assistant.log shows:
024-06-24 13:34:25.911 ERROR (MainThread) [upb_lib.parse_upstart] Cannot open UPStart file: [Errno 2] No such file or directory: ‘config/upstart.upe’
2024-06-24 13:34:25.911 ERROR (MainThread) [homeassistant.components.upb.config_flow] Missing or invalid UPB file: config/upstart.upe

Can anyone help me figure out the correct file path?

I copied the file, upb.upe, into the configuration directory (same one that holds configuration.yaml, etc) and then supplied the UPB integration with the file’s name (and only the file’s name) and it was found.

1 Like

Thank you for the quick reply.

I just tried it again and received the same results.

I have confirmed that the upb.upe file is in the same folder as the configuration.yaml file.

The error message indicates “missing or invalid”
It doesn’t appear to be missing so the next step is to confirm the file’s contents are valid.

According to the documentation:

To create an export, in UPStart , click the UPB button in the top left and select Export to File . This will create a file with the .upe extension. The file must be placed in the configuration directory of your Home Assistant installation.

If you followed those instructions, the resulting file should, in theory, have valid contents.

Thank you so much for the help!

The problem was that I was using the config directory in the file name and there was a problem with my upstart export file.

Now that I exported a new file from upstart and used just the file name for the file path everything is now working .

Thanks again!

I’m having a similar problem. No matter what I do I keep getting the same Missing or invalid UPB file. I am using the same export file that I use for Homeseer. The file works there and seems to be no issue. I’m looking for any assistance that can be provided to validate the file. I was looking through the upstart export file and notice that I have names on devices with special characters such as ’ and @. Would this cause a problem?

2024-07-07 12:11:12.089 INFO (MainThread) [upb_lib.upb] Using flags: {‘’: True}
2024-07-07 12:11:12.089 ERROR (MainThread) [homeassistant.components.upb.config_flow] Missing or invalid UPB file: upb.upe

-rw-r–r-- 1 root root 2 Jul 4 20:09 automations.yaml
drwxr-xr-x 4 root root 4096 Jul 4 20:09 blueprints
-rw-r–r-- 1 root root 651 Jul 7 12:03 configuration.yaml
drwxr-xr-x 2 root root 4096 Jul 4 20:09 deps
-rw-r–r-- 1 root root 3100 Jul 7 12:11 home-assistant.log
-rw-r–r-- 1 root root 3504 Jul 7 11:40 home-assistant.log.1
-rw-r–r-- 1 root root 0 Jul 7 12:08 home-assistant.log.fault
-rw-r–r-- 1 root root 1957888 Jul 7 12:05 home-assistant_v2.db
-rw-r–r-- 1 root root 32768 Jul 7 12:36 home-assistant_v2.db-shm
-rw-r–r-- 1 root root 1001192 Jul 7 12:36 home-assistant_v2.db-wal
-rw-r–r-- 1 root root 0 Jul 4 20:09 scenes.yaml
-rw-r–r-- 1 root root 0 Jul 4 20:09 scripts.yaml
-rw-r–r-- 1 root root 161 Jul 4 20:09 secrets.yaml
-rwxr–r-- 1 root root 43423 Jul 6 14:40 test.upe
-rwxr–r-- 1 root root 52022 May 24 2021 test1.upe
drwxr-xr-x 2 root root 4096 Jul 4 20:09 tts
-rwxrwxrwx 1 root root 43423 Jul 7 10:57 upb.upe

I’m tearing my hair out here. I am having the same issues, and I can’t seem to figure out what the problem is. I have exported the UPE file a half dozen times and placed in the appropriate directory, but can’t get the file recognized. I don’t have any special characters in the device names, but I do have spaces in some of the room names and devices names. Could that be causing an issue?

I’m trying to move away from homeseer and this isn’t an auspicious start.

John - did you figure out what was wrong with your UPE file?


I never did find out what was wrong with my .UPE file, I just re-exported a new file from UpStart and that one worked.

The other issue was that I was using /config in the file path. You just need to enter the filename.UPE

This is what ended up working for me:

I tried the filename by itself and in seemingly all combinations of the path. I re-exported the file and uploaded through the file editor in HA. I connected the samba share and exported it directly the to the config directory. At this point, all I can guess is that there is something funky about my config file or one of my naming conventions that HA doesn’t like.

It worked in Homeseer…

I’ll keep poking at it.

Check the Log for any related errors.

My naming scheme includes spaces and that hasn’t prevented the UPB integration from importing the exported file.

I condensed my upstart export file down to one device with one simple name called office. It still didn’t work. I have exported with multiple versions of Upstart to no avail. I’m at a complete loss. I continue to get the same message

2024-07-08 14:46:13.327 ERROR (MainThread) [homeassistant.components.upb.config_flow] Missing or invalid UPB file: /config/singledevice1.upe

I’ve tried singledevice1.upe, /singledevice1.upe, /config/singledevice1.upe I even renamed to upb.upe based on a post I saw while searching. Nothing is working and it’s not clear where the problem is. The file is in the /config directory for HA. I’m really wanting to make this work. I want to move away from Homeseer4. I’ve been using the software for over 10 years and they are making changes that I don’t like.

Please help. I’m at a total loss here.


I did the same. Direct export to samba share. I wonder if something is going on there? This is outside my wheelhouse of knowledge, but it looks like you and I have completed very similar steps.

As an experiment, export from UPstart to the same (Windows) computer that you’re running UPstart. Then copy the exported file to the computer running Home Assistant.

FWIW, that’s what I normally do .

Hey, author here. I wasn’t aware of this thread until today.

Looks like there might be a bug for those who are adding the integration. If you have the integration already added, like myself and @123, it works.

I’m working on it!

Should make the 2024.7.2 if accepted quickly.

1 Like

That is great news. Thanks for the quick response. I’ll keep my eyes on it.

Thank you @gwww for the quick fix. I’m eager to migrate over to HA. UPB is my largest installation and thus it’s a must for me. Thank you again.