Unknown device Fibaro wall plug (SOLVED)

Hi everyone, i’ve recently (today) bought a fibaro wall plug (FGWPF-102 ZW5 v3.2) and if i add it to homeassistant through the zwave panel it shows up as unknown device and can’t change any config values.

I’m running home-assistant 0.69.1 in a docker container. Can i maybe update the open zwave package?

Thanks in advance.

Solved this. in another topic:

I had the same problem with the FGWPF-102 ZW5. This is because the python-openzwave package homeassistant uses doesn’t have the config for the newer model and therefore shows up as unknown. I’ve fixed this by manually adding it to my zwcf*.cfg file.

I’ve found the correct file in the openzwave C++ github:
GitHub 1

open-zwave - a C++ library to control Z-Wave Networks via a USB Z-Wave Controller.

Then i’ve changed the name of the unknown device in the .cfg file

And the i’ve added the values i found on the github between these tags

NOTE: You’ll need to stop homeassistant before changing these values.