"Unknown error occurred" when trying to add Apple iCloud Integration

I have tried to add the Apple iCloud integration and when I am prompted for my credentials I enter them and click Submit and after around 2-5 minutes eventually am returned a red “Unknown error occurred”.

I tried to add the following to my config/configuration.yaml file to get more verbose reporting of what is going on but I do not see any log events in ha core log than are not usually there:

  default: info
    homeassistant.components.icloud: debug

I cannot google around for this issue because it is so clouded with that issue we all know and love about Apple changing up 2FA and us getting notifications all the time that our iCloud account was being signed into, etc. If anyone knows why I might get this error or at least help me to further troubleshoot in general how to get more details on what is going on under the hood that I am getting what appears to be a timeout I would greatly appreciate it!

This seems to be an IPv6 issue but you have to connect to the host system and not the containerized hosted HA. I fixed this from this thread: Unable to reach the home assistant cloud - Nabu Casa

# Change as your network requires
ssh -p 22222 [email protected]
nmcli con show
# Note down the NAMES of the connections you have and substitute with the ones in quotes
nmcli con modify "Wired connection 1" ipv6.method disabled
nmcli con modify "my-network" ipv6.method disabled