Unknown error registering/connecting HUE bridge

I have tried a lot to connect to the HUE bridge.
Read some resolve:

  1. unplug power of hue bridge, 2. restart router, 3, restart HA, 4. assigne static IP (config in route unifi express and in HUE app). - unfortunately didn/t help…:frowning:

Yes both HA and hue bridge are in the same VLAN (x.x.10.x)

I’m at wits end…Somebody has a suggestion what I can do?

version HA

  • Core 2024.6.3
  • Supervisor 2024.06.0
  • Operating System12.3
  • Frontend 20240610.1

Version HUE: 1.65.196501730


First off, can you control anything with the Hue app?

Secondly, is the IP address showing inside the Hue app the same as you assigned in your router?

Home Assistant should be able to see the bridge automatically, but the integration can be manually added as well. Have you tried that route?

I can control the hue app via my iPhone - no problem there.

The fixed IP address is the same in the router and the Hue app.

Manual adding (by entering the ip address by myself) I’ve tried - same result (error message registration failed-try again).

Any other recommendations?
Do I have to change a config file in HA to write down the fixed IP address in HA?

Do you have any other network connections to Home Assistant? To me, it almost sounds like your router is blocking you. Curious if any other connections work?

Dunno…how can I check?
I’m running HA on my MacBook Pro in Virtual box. Both HA and MBPro has x.x.10.181.

For example, do you have any additional integrations that communicate with HA? For example, I have Roku, LG TV, Wiz bulbs, and TP Link switches all working over local network to communicate directly with HA. I use the Home Assistant app for those devices and have them built into automations. They only work because HA can “see” them on the network.

I’m not familiar with your router and do not use a VLAN which both could be posing problems for your setup.

I had the same thought that my router is blocking me…As I’ve other integrations working fine thsi should nog be the case…enphase (solar cells), sonos speakers, honeywell heating app just to name a few…all working fine.

How can I view/dowload a detailed errorlog that I can share? Perhaps this will help…

In Settings> System> Logs, do you see any errors after you try to add Hue? That may help. Also, check the other log options besides Core to see if anything stands out.

There’s a chance you already have Hue setup in the system in a corrupted way. SmartThings frequently has this happen where you have to remove the old hidden SmartThings file if you remove the integration and add the integration again.