'Unknown' status from Nest protect


Just added a Nest Protect to the house and added it to HA. However I get an ‘Unknown status’ for all the sensors.

HA 0.32.2

Relevant config:

  username: <email address>
  password: !secret nest
  - platform: nest
      - 'smoke_status'
      - 'co_status'
      - 'battery_level'

Nothing in the logs. My username and password are copied and pasted in and I have checked for trailing spaces etc. Also tried with my password in the configuration.yaml rather than in the secrets file.

Any help would be appreciated.

I have the same problem and happened straight after I updated to latest version 32. I guess it broke something!

1 Like

Cheers for the reply Snarby,

I only got the Protect today and installed it up. I was running 0.32.2 for a day before I got it. I know there are a couple of people using Nest Protects here, perhaps there will be a fix coming.

Would a bug need to be logged?

When weirdness happens like something that always worked all of a sudden not working, the first place I search is GitHub issues. I do that, and if I don’t find something I come here and see if it’s just me and then ask if anybody is going to raise an issue on GitHub. Also, spend time browsing the Pull Requests on a regular basis - you can find if one of your issues is going to be fixed and it’s a great way to stay in front of changes and new features.

In short, you don’t have to be a hard core dev to find value in the HA GitHub repo. I just wanted to pass that on as well as this:


1 Like

I just noticed this - talk about rotten timing… But yeah, I’m in the same boat.


Live and learn. If nothing else browsing GitHub should cut down on the amount of noise in the forums.

I appreciate it rpitera.

1 Like

Hope my point wasn’t misunderstood; questions are always welcome here and I try to answer as many as I can. I just wanted to pass on some info I learned to provide additional resources. Sometimes my phrasing can be awkward.

Not at all, perfectly put. I should know better anyway :wink:

1 Like

For the record a downgrade to 0.31.1 has the Nest Protect working again.

Thanks to @rpitera and @tchellomello, greatly appreciated guys.


That’s just for testing though - downgrading could break other things so I would roll it back up while this is being addressed.

1 Like