Unraid / Duckdns / Nginx Proxy Manager

I have my Hassio running on a VM in Unraid (Hassio has a own IP). This works fine. On Unraid I also have installed Nextcloud. To Access the Nextcloud I am using duckdns and Nginx Proxy Manager. This works fine as well. But now I want to use duckdns to access hassio. But this makes problems. I have installed the duckdns addon in Hassio. But when I want to access hassio via duckdns (I have created a own domain for hassio) I only come to the Nginx Proxy Manager welcome screen. I have tried to configure Nginx but without luck. (I have tried settings in unraid and in hassio but nothing has worked). I have no idea how I should set up this construct. Has someone an idea?

I have found the problem.

The solution was quite simple. I just forgot the port when entering the external address.

For all who are looking for the solution here some more detail on how I configured it:

In Unraid:

Configure only nextcloud and the Nginx Proxy Manager.

Set the port forwarding accordingly.

In Hassio:

I have just configured the duckdns addon. (no Nginx Proxy Manager, etc)

In the configuration.yaml enable ssl.

Set the port forwarding accordingly (to the ip address of the vm, not the unraid server) (in my case port 8123)

When using the external address typ: https://xxx.duckdns.org:yyyy/ (xxx ist your domain, yyyy ist the port)

Two more hints: Your rouder need to support Nat loopback. And if you are using a Wireless (LTE) connection you need to apply for an own public ip (at least for my provider).

Thanks for the response.

Unfortional, I have found another problem. I can access my server from the internal network. This works via the ip andress as well as the xxx.duckdns.org address. (for both nextcloud and hassio) But when I want to access the server via an external connection it is not working. All the ports should be set up correctly (port forwarding). I have also asked my LTE provider and they are not blocking any ports. I also have my own external ip. I have no idea what can cause this behavior.

My setup. I am using a Huawei b525s in bridge mode and an netgear ax40v2. I have an ax40 in my old setup and there it is working fine. (but there a wired internet connection).

I use nginx but not via NPM. Surely you would not need the duckdns addon in HA and instead just need to configure something in NPM to point to the Hassio VM.

You are much better off doing reverse proxies than forwarding ports.