Unreachable UI after tinkering with deCONZ and ZHA [solved but unknown original cause]

I just had some pretty weird behaviour after trying out my ConBee II.

My setup
  • home assistant version: 0.108.9
  • environment: Synology Virtual Machine Manager, ConBee passed via virtual USB controller
  • other integrations: HomeMatic connected to a RaspberryMatic, HomeKit

First I set up deCONZ, everything working fine inside, no errors in the logs, but I had some problems pairing a switch, so I reset the conbee from inside phoscon and tried it with zha.
I then disabled start on boot for deCONZ, restarted Home Assistant, and set up zha.
All worked fine again and I was able to pair the switch too, but its events had a huge delay. Thought a restart might help, but after restarting from the UI, the UI didn’t become available again; also ssh didn’t work anymore, both stating “Connection refused”. Home Assistant was pingable.

To solve this, I tried the following to no avail:

  • reboot the VM
  • disable the USB controller and reboot the VM
  • enable the controller but don’t pass the ConBee
  • wait about half an hour
  • empty caches (though this wouldn’t explain the ssh unavailability)

What solved the issues was using the “core check” command from the cli.
From its description, I thought it would only ‘check’ the configuration and not actually repair anything, but after running the command the UI became immediately available again just like ssh.
Everything kept working as expected after some reboots too.

My issue seems solved, however I would be interested in what went wrong with my setup, as I hadn’t made any changes to the configuration before the problematic restart (apart from some automations with lights which I checked with Check Configuration).
Also, why did core check solve the issue? Does the “validates” in its description in this case include repairing if something erroneous is found too?