Unsupported system after upgrade to 2022.11

I’ve got the following issues appearing after the upgrade to 2022.11
Please advise how to fix.

1 Like

that last one is easy – edit your configuration.yaml file and remove the mqtt: block

try clicking on the others to get more information

Yeah, the last one seems to be trivial, already did the fix.
Docker - I did what was recommended and it disappeared.
And regarding the former three issues - I have no clue.

Operating system says it should be Debian, OK, I’m on Ubuntu since 2018, no problems. Should I ignore it?
Systemd Journal Issues - The systemd-journal-gatewayd service needs to be running on the host and exposed to supervisor via unix socket.
I never experienced this notice before.
Unsupported Software - Remove any additional software (including standalone containers) you have installed on your host and restart the Supervisor.
A-ha, very funny :slight_smile:

see this discussion:

and this issue:


I am spinning in circles.
I have installed everything several times, enabled, started, rebooted, started again - the error message remains. In the meantime the Journal Gateway Service is running, but my system is still unsupported. It is just as BebeMischa described it.

I had same issues, and I solved them with:

sudo apt-get install systemd-journal-remote -y


sudo apt --fix-broken install


sudo reboot

What does this command exactly do?

In fact,

when I applied the first command, it told me to do: sudo apt --fix-broken install
I did, and finaly it solved my docker troubles

I had no such message, but gave it a try now: returned that there’s nothing to do.

Well… running ubuntu you have been unsupported for a year or so just didn’t realise it before I guess.
I think the fix for the systemd recommends reinstalling? That’s what I did and it fixed everything up without losing anything.
HA has screwed anyone over who is running any other containers as well. I am unhealthy and unsupported. You CAN set HA to ignore unhealthy so you aren’t blocked from updating and you can ignore unsupported with no ill effects.

1 Like

Now that I recall, it had me do that as well

Well, after I presumably fixed Unhealty system - Docker misconfigured by adding

"log-driver": "journald"

to daemon.json

apparently the message disappeared.

After a while I got new (now - critical) issue:

which is described as below:

So, is this really critical or can be ignored?
Just in case - all my docker containers are running well & healthy.

Also on Ubuntu for years, now 22.04. You may be running into this: CGroup Version - Home Assistant

To use cgroup v1 you can:

  • edit /etc/default/grub
  • add systemd.unified_cgroup_hierarchy=0 to GRUB_CMDLINE_LINUX
  • update-grub
  • reboot

This didn’t make any noticeable difference for me other than “docker info” shows Cgroup Version: 1

I found this thread looking for a way to perma-ignore the “Unsupported system” notices. I have 2, one for Operating System, and one for Unsupported software for a rogue nginx container I setup.

I can ignore them and they go away, but they come right back after restarting hassio-supervisor. I’m looking for something along the lines of ha jobs options --ignore-conditions unsupported but that doesn’t seem to be a thing. Anyone know of other ways?

1 Like

Just ignore it. That’s what I do

Just ignore it. That’s what I do

I like staying current so the orange badge on the settings icon bugs me :slight_smile:

thats helped mi a lot with debian

Bug Report: installation steps don't mention enabling and mapping `systemd-journal-gatewayd` · Issue #247 · home-assistant/supervised-installer · GitHub

1 Like

Hi, can you let me know how to do that? I’ve been stuck on version 2022.11 :frowning:

from the cli

ha jobs options --ignore-conditions healthy