Update 0.73 to 0.82-what do I need to know

I haven’t updated since release 0.73 and just ran sudo pip upgrade and quite a few error messages occured. I restarted the system and it looks like it continued the upgrade on restart.

I’ve tried to log on and it has prompted me for a name, userID and a password which I supplied. I didn’t use these on 0.73.

As it is now, I can no longer access HA outside the LAN. HADashboard is no longer displaying my icons. I do understand there was a change to authentication on release 0.77 but what do I need to change to get my system back working the way it was in 0.73. I’m assuming I will need to change configuration files to allow for these changes in the releases

My system is a Raspberry Pi3 running Raspbian Stretch Lite with a Home Assistant virtualenv installation

Just registering my interest by this comment, as I am yet to upgrade mine, which is on .73 as was yours, and also in a Rasbian venv.

All you guys need to know is in the release notes on the blog: https://www.home-assistant.io/blog/

1 Like

Yes I was aware of these notes. The game changer was the 0.77 update. It states that this update would not break your install if you didn’t have authorisation already implemented which I didn’t. No longer having access to services I mentioned above has broken my install in my opinion.

The remark at the end of these notes was to visit to the community if you were experiencing difficulties with your update, which I am. Now I being directed back to the update notes.

What I am trying to determine is what files I need to edit to restore access to HA outside of my LAN and how I can restore functional access to HADashboard after the update from 0.73 to 0.82.

It appears that update 0.77 was quite a major update. Is it necessary to do incremental updates or can I update directly from 0.73 to 0.82.

Ok so I ran the pip3 install --upgrade homeassistant and here’s the initial output

Traceback (most recent call last):
File “/usr/lib/python3.5/shutil.py”, line 544, in move
os.rename(src, real_dst)
PermissionError: [Errno 13] Permission denied: ‘/srv/homeassistant/lib/python3.5/site-packages/certifi-2018.8.24.dist-info/DESCRIPTION.rst’ -> ‘/tmp/pip-xj7yxoru-uninstall/srv/homeassistant/lib/python3.5/site-packages/certifi-2018.8.24.dist-info/DESCRIPTION.rst’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.5/site-packages/pip/basecommand.py”, line 215, in main
File “/srv/homeassistant/lib/python3.5/site-packages/pip/commands/install.py”, line 360, in run
File “/srv/homeassistant/lib/python3.5/site-packages/pip/req/req_set.py”, line 778, in install
File “/srv/homeassistant/lib/python3.5/site-packages/pip/req/req_install.py”, line 754, in uninstall
File “/srv/homeassistant/lib/python3.5/site-packages/pip/req/req_uninstall.py”, line 115, in remove
File “/srv/homeassistant/lib/python3.5/site-packages/pip/utils/init.py”, line 267, in renames
File “/usr/lib/python3.5/shutil.py”, line 559, in move
PermissionError: [Errno 13] Permission denied: ‘/srv/homeassistant/lib/python3.5/site-packages/certifi-2018.8.24.dist-info/DESCRIPTION.rst’

Rebooted the Raspberry Pi to allow Home Assistant finish the installation process.

0.82.1 is now installed. I was prompted to create a Name, UserID and Password which I did. It then requested my to Login and I supplied the UserId and Password I just created.I am now able to access the UI both inside and outside my LAN but have a persistent message displayed in the centre of the UI

“Login attempt or request with invalid authentication from 192.xxx.x.xx” which is my LAN address for the Raspberry Pi. I also get the same message displaying my web IP address when i attempt to login remotely.

My HADashboard will not display it’s icons displaying the message “entity not found etc,etc”. Clearly something needs to be changed in the appdaemon configuration to resolve this.

I’m wondering if anyone could shed some light on this.

It’s getting crazier now.

I opened a Terminal session and cannot edit any of the configuration files to see if I can remove any of the offending configuration relating to Legacy API Passord. Using the password I created when upgrading. Tried it 3 times and getting

sudo nano configuration.yaml

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

#1) Respect the privacy of others.
#2) Think before you type.
#3) With great power comes great responsibility.

[sudo] password for homeassistant:

Sorry, try again.
[sudo] password for homeassistant:

Sorry, try again.
[sudo] password for homeassistant:

sudo: 3 incorrect password attempts

How can i possibly resolve this now that I cannot access any of the configuration files.

I’ve sorted out the access to the configuration.yaml so I’ve made the necessary changes to get the HADashboard displaying the entities.

My last problem is displaying the generic camera stream in HADashboard. It was working in HADashboard in 0.73 but is not now. I added the
?api_password=jackandjill, my password, to the end of the camera url in the configuration.yaml but stream is not displaying. The stream displays in the HA api and a web browser.

Any ideas what might be wrong here.

Well I’ve tried the long term token I generated in the Appdaemon.yaml file and still cannot display the camera stream in HADashboard. No problem displaying the camera stream in the HA UI.

I’m assuming this is a verification issue between Appdaemon/HADashboard and Hass but I’ve tried everything suggested here and still no luck and no suggestions as to what else I could try.

It’s hard to believe I had everything working perfectly in 0.73. Looks like at this stage I’ll be stuck on 0.73. I did read that the upgrade wouldn’t break a working install but it looks like I might be the exception here.

I’ve read up on the Authenticaion issues and the Short Term and Long Term Tokens along with Legacy passwords, Keys and passwords and am wondering where the whole security situation stands with Home Assistant between the releases 0.73 and 0.82.