Update appDaemon

Tried to install Schedy, and to do that I had to install and update appdaemon.
After a bit of research I installed using these commands on the hassio command line:

apk add python3
pip3 install --upgrade pip
apk add gcc
apk add python3-dev musl-dev linux-headers libffi-dev
pip3 install --upgrade appdaemon

and managed to update app daemon.
The installed commands worked fine:

but when I rebooted I found something interesting:
1st the app daemon still showed the old version:


and when I went to the command line I got these results:


What is going on?
How do I install anything that is not on the add-on store?
How do I get a script to run at startup?
How do I get commands run at the start of any session?

alias ll=‘ls -lah --color=auto’
alias dir=‘ls -lash --color=auto’

Thanks in advance

I understand that you cannot install anything on hassio that is not an addon, but there is an appdaemon addon for hassio.

But don’t ask me where or how because I have never used hassio.

You don’t need to update AppDaemon. The Hassio add-on version is fine.

the schedy installation manual says:

AppDaemon version 3.0.2 or later is required for this to work.

so I had to install a latter version. although in the app daemon page says 3.0.1 in the startup logs says 3.0.4

and what about pip3 and python3 and the startup, or any other installation, gets deleted at reboot?
how to work around it?
where can I put startup and session parameters?

I believe that’s only for the Docker installation. Installation in Hass.io does not call out a version, just that the add-on needs to be set up: