Update Broke MQTT ACLs

Hey everyone <3

seems i am too stupid to find out why one of the last updates broke my mqtt setup :frowning:

does anyone know why those are here:

2022-09-14 10:29:44: Client <unknown> disconnected, not authorised.
2022-09-14 10:29:45: New connection from 192.168.XX.XXX:34898 on port 1883.

i had no anonymous login before the upgrades and use home assistant users for mqtt authorization (one per device) and also have acls in place.

but everything looks like it should work (and has until now).

can someone please help me?

//EDIT1: it seems that the way ACLs work has changed because since i disabled mine it works again…

Did you look at the breaking changes that specifically mention mqtt?

i looked at: https://mosquitto.org/ChangeLog.txt
but i did not notice anything which would affect me but maybe im just blind :confused:

The release notes. Read them before updating.


Support for MQTT climate hold and away modes, which was deprecated in Home Assistant Core 2022.3.0, has been removed. The hold and away modes are replaced by preset_mode.

1.) i dont understand what that means since i dont use climate devices :frowning:
2.) my HA was version 22.08 which worked and is broken since 22.09 or 22.09.1 :confused:
so i dont get why changes from Home Assistant Core 2022.3.0 would affect me that late ?

Try this one:

my sensors are directly from my tasmota smart plugs / valetudo
everything is at its latest version. I guess it has somthing to do with authentication or so since the error message states “Client disconnected, not authorised.”

But i have no clue how to troubleshoot that :frowning:

so i installed mqtt explorer and indeed after the update every user i created with haos (for mqtt devices) gets a connection refused.

@tom_l was there a change in 22.09.x which disabled HAOS users for MQTT authentication? or changed ACL behavior?

What does the home assistant log say?

sorry for the question but which log are you referring to?

i got the message from HAOS Webinterface > Settings > Addons > MQTT > Logs
there it is spammed every time one of my devices trys to connect. Sadly it is not much more detail than what is quoted in my 1st post :confused:

ohh it seems somethings have changed with the acl since i commented out my mqtt acl in share/mosquitto it works again :smiley:

Sadly i did not notice any breaking changes advice regarding mqtt acls :frowning:

my old acl looks like this (which worked until 22.09.x)

@tom_l is there a documentation about the acl changes in haos?