Update doesn't Install

Newbie here so apologies if this is a basic question.

Installed HA on a RPi4 over a couple of days ago and just basically playing with it sense.
Got 2 notifications to update and these seem to go ok.

Now got a notice to update OS from 8.5 to 9.0 but get the following error

[548200718512] Error updating Home Assistant Operating System: 'OSManager.update' blocked from execution, no supervisor internet connection

Any ideas how to resolve? Cant seem to find anything similar in the forums

1 Like

ok…I rebooted the Pi and that seemed to fix the issue…but not sure why?

Any ideas?

Same here on a Pi 3B, coming from HAOS 8.5:

[547931193200] Error updating Home Assistant Operating System: ‘OSManager.update’ blocked from execution, system is not running - CoreState.STARTUP

Several hardware reboots didn’t fix it, unfortunately.

That is not the same error.

1 Like

You are correct. :grinning: I received the other error as well, earlier.

No other services are having problems with network access, which is why I provided the second message in case another user has seen it as well.

Just casting a wide net to see whether someone with more experience than I have recognizes the situation.

Aaaaaand after about a dozen attempts, suddenly today it simply works.

Previous attempts would have a progress indicator for six or eight minutes, which would disappear, then the system would reboot, and then come up still on HAOS 8.5.

I wish I knew what I could do differently next time, other than “wait until Day Two,” I guess. :grinning: