Update from 0.68 to 0.77 broke my MQTT


#1

After upgrading to 0.77 my MQTT broker (the built in one) is no longer working.

The overview page shows:

'The following components and platforms could not be set up:

mqtt
switch.mqtt
light.mqtt

Please check your config’

I’ve never done anything on this Pi for MQTT and just used the built in broker. Did something change between the versions I have that mean you can’t use the built in broker any more?

Thanks!


#2

yeah, make sure you have your password set in the config file

mqtt:
  password: mypass

Mentioned in 0.76 update

https://www.home-assistant.io/blog/

#3

Read the 0.76 release notes!


#4

Well, I did read the release notes and it’s not clear if the mqtt password needs to be set for everyone or just ios folks. I’m on 0.77.3 right now and here’s my configuration.yaml

mqtt:
  broker: pi3
  discovery: true
  discovery_prefix: homeassistant

no password and I’m running just fine with my internal broker (yes, my PI HA host is pi3).


#5

actually it is 0.76 release notes, i have changed the post above.


#6

Thanks, I’ve read the release notes and it mentions to set a password, but where is the other side of this config where I need to enter the matching password to use MQTT? All of the MQTT stuff is in the same config file so it would be a little bizarre to have both the server and client password config in the same file

I’m clearly missing something here…

EDIT: OK, so setting a password in the config has started everything up as before, but where is the password actually used to communicate with MQTT? Or does HA just do this by itself? In which case… what’s the point?


#7

Well your client devices, eg a sensor, or a light, will need to know the password to communicate with the mqtt server.


#8

Hi.

Before 0.76, there was only one password to login to Home Assistant. Thus for simplicity, Home Assistant used this password for the MQTT server. When the new user system was introduced in 0.76, there is no single password to login to Home Assistant by default that MQTT can use and that’s why you have to define a password manually. If you want all your old MQTT devices to work, you need to set your MQTT password to be the http password you used before.

Hope I cleared thing up for you.