Update has maybe failed?!

Just tried to update from 0.94.1 to the latest available version to .0.102.1, it’s been two hours and when I ping the host I get ‘host is down’.
I checked breaking changes and found nothing significant.
Can I safely assume something has gone badly wrong, or should I let it continue?!
I’m wary of pulling the power in case it’s still in progress.

2 hours is a very long time for an update. Normally just a handful of minutes at most. Something has gone wrong.

OK. Thanks.

I’ve had multiple failures this week with my Rpi HA. I don’t know what’s going on recently, but I’m reluctant to do any further updates for a while. Updates failing to take and corrupting the SD Card mainly. This morning I took a full snapshot backup and I’ve just tried to restore it, but it hasn’t backed up my config file or lovelace layout. So I’m back to square one, before the update. Pointless snapshot.

hmmm. I pulled the power and reinstated it, and this time the pi booted. I’ve lost (for some reason) a link in my sidebar to configurator, I can’t access the instance using the iOS app, and the first entry in the log is:

Ended unfinished session (id=40 from 2019-11-23 18:54:17.852293)
12:29 PM components/recorder/__init__.py (WARNING)

I also have:

Timeout on /ingress/panels request
12:32 PM components/hassio/handler.py (ERROR)

I’m also still on 0.92.1. Thoroughly, thoroughly confused.

EDIT: A second reboot has restored the sidebar link and I can now access the instance from the companion app again.

I’m very, very wary of trying the update again!

And similar to you, I lost every single ESP device (16 plugs and 6 sensors). They just all became “unavailable”. I also lost the Samsung TV interface too. Weird.

Even if you get a successful update (no reason you shouldn’t unless there’s something wrong with your SDCard), you are in for a hell of a time troubleshooting all the breaking changes between versions.

Well as I said, I checked, and there didn’t seem to be any breaking changes which would affect my setup?

from .94 to .102? Well that’s impressive if you have no breaking changes between the versions.

I have similar issues since two days ago.

Running hassio on RPI3 for about a year with no major issues after I figured out how the whole thing works. :slight_smile:

I made the mistake of updating hassio as well two days ago. i was up-to-date up until then, i.e. incremental version update. Corrupted my install and never came back.

I make full snapshots every time I update or change something, and put them on dropbox religiously. So I have the snapshots and have put them on the backup directory after a fresh install of hassio and getting ssh back up and running.

Tried “wipe & restore” as well as restore by having everything checked off… Never comes back after that. I tried with the most recent two backups which are in the 0.99 and 1.01 range.

I have done this several times now probably wasted a good 5-6 solid hours, and still have no clue what is holding back the restores.

After the latest “wipe and restore” I can see I can ping the machine but can’t ssh - I think that is already wiped off. Other than being able to ping I don’t have any other diagnostics.

It has been a few hours. Shall I turn the RPI off again or just leave it be?

Imagine that… As soon as I posted… it came up.
I still don’t know why it didn’t work before as I also waited a long time.

fwiw this is backup from a month ago not the latest one that actually worked.