Update home assistant fails

Installed home assistant as vdi file on virtual box.
Update fails with following log:
20-12-14 21:28:59 ERROR (SyncWorker_0) [supervisor.docker.interface] Can’t install homeassistant/qemux86-64-homeassistant:2020.12.0 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2020.12.0&fromImage=homeassistant%2Fqemux86-64-homeassistant: Internal Server Error (“Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:57062->[::1]:53: read: connection refused”).
20-12-14 21:28:59 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed
What can i do ?

1 Like

Same error here. Have you found a solution yet?

Same here on Pi4
Version 2020.12.6

20-12-15 09:39:32 ERROR (SyncWorker_1) [supervisor.docker.interface] Can't install homeassistant/raspberrypi4-homeassistant:2020.12.0 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2020.12.0&fromImage=homeassistant%2Fraspberrypi4-homeassistant: Internal Server Error ("Get "https://registry-1.docker.io/v2/homeassistant/raspberrypi4-homeassistant/manifests/2020.12.0": dial tcp: lookup registry-1.docker.io: no such host").
20-12-15 09:39:32 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

EDIT: A restart fixed my issue

I also ran into the same issue, but as @kabuki mentions above, a full reboot of my Pi4 fixed it (not just a restart of HA, a full power cycle reboot)

In my case, I had to update /etc/systemd/resolved.conf.d/dns_servers.conf to include my DNS server ( For some reason, it didn’t have any entries. After the update, I had to restart systemd-resolved:

systemctl stop systemd-resolved
systemctl start systemd-resolved

Now things are working!

1 Like