Update of Home assistant or addons failed - system not healthy

Tags: #<Tag:0x00007fc410c90230> #<Tag:0x00007fc410c90140>

Hi Freestilla,

I also saw the same messages. I am running Ubuntu:

[email protected]:~$ uname -a
Linux hass 5.4.0-56-generic #62-Ubuntu SMP Mon Nov 23 19:20:19 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
[email protected]:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.1 LTS
Release:	20.04
Codename:	focal

For me upgrading docker-ce and then reboot recolved the issue.

3 Likes

I just had the same problem when trying to upgrade with supervised on ubuntu. Updating all packages and rebooting worked and I could upgrade HA. Then I tried to install a new add on and got the ‘unhealthy system’ error again. Another reboot (to the machine, again) solved that too.

1 Like

Just thought I’d add to this discussion. I had Watchtower installed at one point in my docker environment, but I had sense removed it because of the unhealthy system notification. However, even after removing the Watchtower container, I was still seeing the unhealthy system message. It seems that even if the Watchtower image has been pulled, but not in use in a container; HA will complain about an unhealthy system.

Removing the Watchtowers image from docker fixed it all. As well as updating my Ubuntu 20.04 install.

Worked for me too. upgrade the Ubuntu host, reboot, then Home Assistant upgrades fine.

1 Like

I’m on 19.10 and I had the hope I could wait until I had time to migrate my system to ProxMox for a supported installation. Oh well, fingers crossed. Going to 20.04… shit.

Thanks for the suggestions. I think upgrading docker-ce did it for me.

[email protected]:~$ uname -a
Linux hass 5.4.0-58-generic #64-Ubuntu SMP Wed Dec 9 08:16:25 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
[email protected]:~$ docker version
Client: Docker Engine - Community
 Version:           20.10.1
 API version:       1.41
 Go version:        go1.13.15
 Git commit:        831ebea
 Built:             Tue Dec 15 04:34:58 2020
 OS/Arch:           linux/amd64
 Context:           default
 Experimental:      true

Server: Docker Engine - Community
 Engine:
  Version:          20.10.1
  API version:      1.41 (minimum version 1.12)
  Go version:       go1.13.15
  Git commit:       f001486
  Built:            Tue Dec 15 04:32:52 2020
  OS/Arch:          linux/amd64
  Experimental:     false
 containerd:
  Version:          1.4.3
  GitCommit:        269548fa27e0089a8b8278fc4fc781d7f65a939b
 runc:
  Version:          1.0.0-rc92
  GitCommit:        ff819c7e9184c13b7c2607fe6c30ae19403a7aff
 docker-init:
  Version:          0.19.0
  GitCommit:        de40ad0
[email protected]:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.1 LTS
Release:	20.04
Codename:	focal
1 Like

Hello,

Latest update (Home Assistant 2020.12.1) fails when trying to upgrade.

Solution: restart service hassio-supervisor and service hassio-apparmor

OS system: Ubuntu 20.04

5 Likes

May be try my method

Thanks @dtalens. Ran into the same issue when trying to update to 2020.12.1 and restarting hassio-supervisor worked for me. I didn’t have to restart hassio-apparmor.

1 Like

This simple trick did it also for me. Also rebooted after the upgrade. My error was:

21-01-10 18:06:47 WARNING (MainThread) [supervisor.jobs] ‘HomeAssistantCore.update’ blocked from execution, system is not healthy

3 Likes

yep; it worked. Thanks…

sudo docker restart hassio_supervisor

I don’t have apparmor anyway…

3 Likes

Hi All, I had the same issue - followed the instructions here and can now update

In-case people are unsure what steps to follow, mine was as simple as (this is all above but put the entire issue and resolution in a single post to make it easier for anyone new) - i’m running HassOS on Ubuntu:

Error Received (for both updating the core and an update to the latest version

WARNING (MainThread) [supervisor.jobs] 'AddonManager.update' blocked from execution, system is not healthy
WARNING (MainThread) [supervisor.jobs] 'HomeAssistantCore.update' blocked from execution, system is not healthy

I SSH’d into my server and executed three simple commands

sudo apt-get update
sudo apt-get upgrade
sudo reboot

Waited for it to restart and now i can succesfully update

INFO (MainThread) [supervisor.homeassistant.core] Updating Home Assistant to version 2021.1.4
INFO (SyncWorker_5) [supervisor.docker.interface] Updating image homeassistant/qemux86-64-homeassistant:2021.1.1 to homeassistant/qemux86-64-homeassistant:2021.1.4
INFO (SyncWorker_5) [supervisor.docker.interface] Downloading docker image homeassistant/qemux86-64-homeassistant with tag 2021.1.4

Note: This is a work around and is required each time you want to upgrade if your system isn’t completely up to date Thanks for clarifying this point @badabing

3 Likes

Thanks for this!

I had just installed Ouroboros, a python version of Watchtower, making updating my many containers running on my server very easy! Plus with a notification sent to my phone daily with the list of updated container.
But of course my HA supervisor didn’t like it, even though all HA related container were in the exclusion list in Ouroboros. As you said, after deleting the container and it’s image, HA was healthy and supported again.

Did you find any workaround? Auto-updating is super handy for sure…
I am thinking of a script, to:

  • Create the container - Image will be auto-downloaded if not there (Ouroboros has a “run once option”)
  • Keep it up for maybe 15-20 minutes
  • Stop the container
  • Delete the container
  • Delete the image

All this managed by CRON…

@mitch
That will only get you working temporarily,
Soon after you’d notice that it is back to being problematic.

@dtalens
Thank you, that approach is much easier and quicker then a full update / reboot

What I don’t get is that I had docker in Ubuntu method working for very long time and very steadily, and all of a sudden with some Supervisor upgrade this problem started happening, and on every Home Assistant Update or on every Add-on update I have to do this dance to get it working.

I get it, it is not officially supported, but as seen in this thread and many others, lots of people are using this setup.
Why intentionally break it?
If a reboot fixes it, or if a supervisor restart fixes it, it is obvious that at some point after the restart, supervisor is running some script process to check things out and declaring it to be unsupported, effectively blocking updates.
Seeing that people have no choice but to restart the system or supervisor to proceed, and are doing so, why not add a configuration option to allow ignoring this unsupported flag and proceed regardless? Put a big warning if you want to discourage people, but forcing people to find workarounds and loopholes is not the best deterrent.

I have one system, which is an Ubuntu system, it is powerful and runs many other services aside from Dockerized Home Assistant, asking us to switch to Debian where this setup has been working for a very long time is unrealistic.

I’m not asking for it to be officially supported, what I’m asking is for it not to be intentionally handicapped.

4 Likes

@badabing
I have exactly the same setup and issue you describe. +1

Absolutely, I spend hours to figure out why my system thinks it might be unhealthy instead of fixing it when it is really unhealthy.

GNU Debian and latest version of Docker installed two weeks ago after my Raspian install would no longer run Supervisor reliably. Supervisor would stop after 5 mins to 1 day with no error.
Today I see supervisor has no access to the internet and getting similar messages in log. Reboot, update and upgrade reboot, remove WG and DuckDNS reboot, add loopback to etc/host reboot all failed. Tried restarting Docker container for Supervisor and have a clean log file. However, after a reboot i get

19-02-14 10:12:53 WARNING (MainThread) [supervisor.updater] Can't fetch versions from https://version.home-assistant.io/stable.json: Cannot connect to host version.home-assistant.io:443 ssl:True [SSLCertVerificationError: (1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: certificate is not yet valid (_ssl.c:1125)')]
19-02-14 10:12:53 WARNING (MainThread) [supervisor.jobs] 'Updater.fetch_data' blocked from execution, no supervisor internet connection
19-02-14 10:12:53 INFO (MainThread) [supervisor.homeassistant.secrets] Loaded 6 Home Assistant secrets
19-02-14 10:12:53 INFO (SyncWorker_1) [supervisor.docker.interface] Attaching to homeassistant/raspberrypi4-homeassistant with version 2021.3.4
19-02-14 10:12:53 INFO (MainThread) [supervisor.hassos] No Home Assistant Operating System found
19-02-14 10:12:54 WARNING (MainThread) [supervisor.jobs] 'StoreManager.update_repositories' blocked from execution, no supervisor internet connection

Your time is wrong.
It thinks the certificate is in the future so won’t connect to the server.
Set your time.

@dtalens, thanks!
It worked for me.

sudo docker restart hassio_supervisor

Yes, this solved the problem for me.

Followed the instructions to update from here: Install Docker Engine on Debian | Docker Documentation (However I did not apply uninstall)