Update OpenZwave Hassio with HassOS

Hi, This weekend I got an MCO Home MH7-EH (Electrical heater with Zwave + , http://www.mcohome.com/show_list.php?id=14&sid=49), but HA says it’s an unknown device ( zwave.mcohome_unknown_type_0702_id_5102).

I did some research and find out that the device is supported with OpenZwave, they recently updated their files to support it (https://github.com/OpenZWave/open-zwave/tree/master/config/mcohome).

So it seems that I need to update my files on my installation. I’ve found out that its quite easy on all installations, but I can’t find it for an HassIO installation with HassOS. It seems you cannot manually update the xml files on that type of installtion.

I also tried the service zwave.update_config and I saw my installation connects to GitHub to download files, but it doesn’t resolve the issue.

Hass io supervisor

Version 143
Latest version 143

Host system

System HassOS 2.8
Deployment production

Home Assistant version : 0.87.0

Can anyone help me or point me in the right direction ?

@SMAW did you ever find a solution to this. I’m also having trouble finding a way to update OZW with Hass.IO.


Hi ,

Yes I resolved it by creating a directory zwave in de config directory, after that i cloned the OpenZwave repository in this directory. (https://github.com/OpenZWave/open-zwave)

After that changed the configuration.yaml with the following :

  usb_path: /dev/ttyACMXX <-- Change this to your port
  config_path: /config/zwave/config 

After a restart it worked.

I followed the instructions and put the config folder from InovelliUSA/OpenZWave and added the config_path below. Now my Z-Wave USB can’t be found.

# Aeotec Z-Stick Gen5 USB
  usb_path: /dev/ttyACM0
  config_path: /config/OpenZWave/config/

Those files aren’t compatible with HA. You should install the 1.4 version.

I actually realize that after I posted and used the suggested link https://github.com/OpenZWave/open-zwave. Now all works. Thanks!