Update Operating System to version null?

Tags: #<Tag:0x00007f32703bed50>

I’m setting up a fresh install of HassOS using the qcow2 image running on KVM. Just booted into it. Seems to have already updated itself to v117, that’s cool. When I click into Supervisor, it’s kindly offering to update the Operating System from v4.15 to “null”. It says “Are you sure you want to update the Operating System to version null” ? That doesn’t feel good… Any ideas on what I should look for ?

Thanks for correcting my category @Tinkerer

1 Like

I have the same problem, also looking for a solution.

I have the same problem, I am also running a new qcow2 image running on proxmox.

Same Issues here.

Same here yes! Using a fresh OVA installation.

Version: HassOS Release-4 build 16 (Stable)

Log says:
20-11-07 14:44:41 INFO (MainThread) [supervisor.hassos] Fetch OTA update from https://github.com/home-assistant/operating-system/releases/download/None/hassos_ova-None.raucb

Absolutely the same here with a fresh VDI from the website.

Now the update is gone. No error though.

Same here with the qcow2 disk.

I had this with a new install of the NUC image on a Wyse thin client.
I used the Developer tools to set the Updater binary sensor to “off”, then rebooted. That removed the false update notice, and updates have worked fine since.

Hm, this sounds like a supervisor issue. @phaked (or somebody else) can you open an issue at https://github.com/home-assistant/supervisor/issues along with Supervisor logs?

Done: https://github.com/home-assistant/supervisor/issues/2256

Setting the Update to binary sensor to “off” solved it for me.

Good stuff. And, for peace of mind, since I did this, the update system has worked without issue.

1 Like