Update problem

Hi, I cannot update hass. I don’t know why. I already removed al .pyc files. But didn’t work out.
I have a back-up from a couple of weeks ago. So if this is not a known problem I will try to update again after I put the backup again on the bbb.

This is the output I have:

hass@beaglebone:/home/bart$ source /srv/hass/hass_venv/bin/activate
(hass_venv) hass@beaglebone:/home/bart$ pip3 install --upgrade homeassistant
Traceback (most recent call last):
  File "/srv/hass/hass_venv/bin/pip3", line 7, in <module>
    from pip import main
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/pip/__init__.py", line 14, in <module>
    from pip.utils import get_installed_distributions, get_prog
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/pip/utils/__init__.py", line 27, in <module>
    from pip._vendor import pkg_resources
  File "/srv/hass/hass_venv/lib/python3.4/site-packages/pip/_vendor/pkg_resources/__init__.py", line 71, in <module>
  File "<frozen importlib._bootstrap>", line 2237, in _find_and_load
  File "<frozen importlib._bootstrap>", line 2226, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 1200, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 1129, in _exec
  File "<frozen importlib._bootstrap>", line 1467, in exec_module
  File "<frozen importlib._bootstrap>", line 1570, in get_code
  File "<frozen importlib._bootstrap>", line 656, in _compile_bytecode
ValueError: bad marshal data (unknown type code)

Looks like it might be corrupted bytecode:

Already tried but didn’t work.

@bart did you ever find a resolution to this issue. I am experiencing the same situation.

No, i did a new install of Debian and home assistant. Seems that there were a few corrupt files. But I don’t know which files. Fastest and best solution was the new installation. I backuped the configuration.yaml file of course.

Probably the reason of these errors was that I ran the os from an sd card which is more sensitive for writing errors. Now I installed everything on the internal storage.

thanks for the reply… reinstalling HA did resolve my issue as well.