Update Supervisor fails

How can I fix this error?

20-06-19 03:47:48 CRITICAL (MainThread) [supervisor.core] Update of Supervisor fails!
20-06-19 03:47:48 CRITICAL (MainThread) [supervisor.core] System running in a unhealthy state. Please update you OS or software!

Did you try that?

Hi David,
Sorry… Do you mean OS as in Windows?
I am running HA in a VirtualBox on a Windows NUC

I hit the update button on Supervisor Dashboard but it wont update


Ah so you are running 228 but 227 is ‘available’ so you are on the latest no?
Not familiar with Virtual Box - that is a VM right? what is the O/S in the VM it is running on? Is that O/S up-to-date?

The issue with being offered an old supervisor (which 227 is) is that the version json file isn’t up-to-date yet. 227 is what I am running and appears to be the latest

EDIT: 227 is definitely the latest https://github.com/home-assistant/supervisor/releases

Perhaps reload the supervisor from the system tab

Yes… VirtualBox is VM. t is running Ubuntu (64 bit). I downloaded it from HERE over the weekend for a fresh install. So, I assume it is the latest version.
The error is confusing to me… I m running 228 but 227 is available. I would think it should be the other way around.
I reloaded and the error went away


yeah as per my suggestion.
Um… if you installed from that page I don’t think you installed Ubuntu - looks like HassOS to me…
See here

I’m guessing yours doesn’t show the Installation Type as Supervised?

Hmm… It is HASS OS (good call)
I loaded from the VMDK (it’s headless)
Maybe I should have simply installed onto a traditional Ubuntu VM

It’s up to you.
If you do decide to switch be aware that Ubuntu is not a supported O/S so you will want Debian (which is). Or just stick with HassOS - no reason not to and HA will offer O/S updates as they become available.

Just reboot your VM.
Had the same on my play HA in VBox a few days ago.

Thanks both

Same here.

Same running HA 111.4 in VirtualBox on Windows 2019 server.

Reload or rebooting does not resolve this here.

Kind of scary CRITICAL error message, in blood red.

Same problem here on a brand new hass OS install

Not sure if anyone else has Ouroboros installed - but this was my issue, as it was constantly attempting to update the Supervisor container. I’m sure you could configure to ignore, but I removed Ouroboros and this error stopped appearing as did the same warnings in the OP. The same may apply to Watchtower?

Using Hassio on RPi 4. Had the same issue and a reboot resolved it.

Hie guys & girls !!

I can’t update anything or install Addon since a week :

I already checked lot of things like my firewall, my port on the routeur…
I tried to rename the custom components folder then I restart

An other things looks strange is that my time & date are UTC and ISO are not the good one (the same in the log). (We are the 06 april 2021 but it is wrotten the 15 January ) :wink:

Does could be the problem with the NTP servers and how can I resolve the problem please :pray:t2:

I also can’t install Add-on since that problem :woozy_face:

Here is my configuration :
Sorry it is in French, hope it is ok for you.

Update :

Solved after a week like this for myself :
IP on the HA host --> DHCP
IP on my router --> IP static
In Portainer --> Deleting the image of the supervisor
restart host

In SSH -->
ha jobs options --ignore-conditions healthy
(thanks @DavidFW1960 for help :+1:t2: :wink: )

ha supervisor update
ha core update
ha host update
ha jobs reset
ha supervisor restart