Update to 0.117 just bricked my system

Confirmed. It gave me a green tick too.

If you put a keyboard on your RPi you will login as root. Then login to the OS. Then browse to /mnt/data/supervisor/homeassistant/

Hassio Recovery

…or 0.117.2

Saddle up, it’s go time !

Hello, my RPi4 is totally bricked since 2 days, I tried 2 times to reinstall everything from scratch and do a Wipe Restore but this is making it hang forever.
Today at the 3rd try I noticed the hass.io I installed is 0.117 but the version I was using before the crash was older.
So I guess this is the problem.
Is it possible to install the version I had before the crash?
If not how can I do a restore that will not crash again?
Should I select just some parts from the snapshot and which ones are safe?
I had custom_components and hacs as special things, otherwise it was all standard add-ons.

Your Pi4 is not bricked, you just have a faulty installation most likely due to a breaking change in your configuration that you need to update.

Hass.io was renamed some time ago, please see HERE for correct naming.

Yes - Install the most current version of HA, upload and restore a previous snapshot. I would recommend you start basic and make sure that the items under Home Assistant (in green) are checked, and that any add-ons (in red) are unchecked, then restore.

Thanks for your reply.
My RPi4 is totally unresponsive, I can’t even move the cursor on the display, HA takes all CPU.
So only solution is format of the SSD and reinstall everything.
I tried to Restore (not Wipe Restore) without checking HA and the add-ons, it kind of worked but after I started adding the custom dashboards it crashed again …
This is really annoying as I have no way to stop it once it becomes unresponsive.
My last backup was made on 0.112

Set up ssh access.

SSH is also unresponsive, of course I do everything through SSH.

Still playing with my system, trying to restore different snapshots and see which of them work and which not.
Now I restore an older snapshot, I noticed the following in the System Logs:

20-11-10 15:36:51 INFO (MainThread) [supervisor.snapshots] Found 5 snapshot files
20-11-10 15:36:51 INFO (MainThread) [supervisor.discovery] Loaded 0 messages
20-11-10 15:36:51 INFO (MainThread) [supervisor.ingress] Loaded 3 ingress sessions
20-11-10 15:36:51 ERROR (MainThread) [supervisor.core] Detected unsupported OS: Raspbian GNU/Linux 10 (buster)
20-11-10 15:36:51 ERROR (MainThread) [supervisor.core] NetworkManager is not correctly configured
20-11-10 15:36:51 INFO (MainThread) [__main__] Running Supervisor
20-11-10 15:36:51 WARNING (MainThread) [supervisor.core] System running in a unsupported environment!
20-11-10 15:36:51 INFO (MainThread) [supervisor.addons] Phase 'AddonStartup.INITIALIZE' starting 0 add-ons
20-11-10 15:36:51 INFO (MainThread) [supervisor.addons] Phase 'AddonStartup.SYSTEM' starting 0 add-ons
20-11-10 15:36:51 INFO (MainThread) [supervisor.addons] Phase 'AddonStartup.SERVICES' starting 3 add-ons

I get this warning in Supervisor … I have raspbian buster, is that not ok?
Also there is an error related to Network Manager

After trying do make the update 0.117, my RPI3 is also bricked.
In the previous version, I made full snapshot, saved on the SDCard.
I understood the steps to fix the issue : install a clean version, then restore the snapshot.
–> I have a question. My snapshot is on the SDcard. How to proceed to install a new version and get the snapshot that is on that SDcard ?
Thks in advance

Copy with some utility the backup folder from the SD card, maybe all the hassio folder is even better.
There is a script above, I used it after installing Docker.
Then login to the new HA, configure Samba and copy the .tar files back in the backup folder, then you should be able to see them and restore the snapshots.

Maybe you can post some actual advice, instead of copy pasting some link to some scripts…

Maybe you could read the information kanga_who kindly provided and see that it is not “scripts” but the details required for a supported supervised system, and it answers your question.


This is exactly what I need, another riddle.
Of course I read many times what he posted, still no clue why my system does not work.
I even used the script to install it, so really not helping, sorry to say that.

Did you read this bit:

Debian Linux Debian 10 aka Buster (no derivatives)

I’m not saying it can’t work, just that it is unsupported.

I have raspbian buster updated/upgraded to the latest.
It worked for 6 months on this raspbian so I really don’t understand … and you like riddles it seems.

I don’t know how much simpler I can make it. This is not a riddle.

The ADR requires:

Debian Linux Debian 10 aka Buster


You have the derivative:

It most likely broke because you are running an unsupported system.

1 Like