Update to 0.42


I did update my HA to 0.42.2 right now, usally its no problems.
But this time the sensor.rfxtrx did stop working.

This is what I see in the logs:

Please report the following info at http://bit.ly/2ogP58T : switch.vera, verisure, vera, sensor.history_stats, updater, input_select, group, logbook, panel_iframe, camera.mjpeg, light, scene.homeassistant, switch.rfxtrx, ifttt, cover, camera.verisure, config, cover.vera, binary_sensor.vera, climate.vera, light.vera, recorder, sensor.vera, zone, lock.verisure, climate, tts, config.core, alarm_control_panel.verisure, scene, camera.ffmpeg, switch.verisure, automation, camera, sensor.verisure, sensor.android_ip_webcam, binary_sensor, lock.vera, api, alert, alarm_control_panel, ffmpeg, lock, frontend, config.group, switch, sensor.time_date, websocket_api, android_ip_webcam, sensor, media_player, discovery, http, mqtt, camera.generic, alarm_control_panel.manual, conversation, sun, sensor.openweathermap, sensor.template, sensor.speedtest, device_tracker, sensor.yr, history, media_player.cast, notify, light.rfxtrx, rfxtrx
17-04-09 19:43:44 WARNING (MainThread) [homeassistant.helpers.entity] Update for sensor.lamp_on_today is already in progress

Also this:

17-04-09 19:42:07 ERROR (MainThread) [homeassistant.config] Invalid config for [sensor.rfxtrx]: Rfxtrx device 0a52091bbf0000e0240289_temperature is invalid: Invalid device id for OrderedDict([(‘0a52091bbf0000e0240289_temperature’, OrderedDict([(‘name’, ‘Utomhus’)])), (‘0a5202009e010036480379’, OrderedDict([(‘name’, ‘Krypgrunden’), (‘data_type’, [‘Humidity’, ‘Temperature’])])), (‘0a520201b30100c01a0269’, OrderedDict([(‘name’, ‘Källaren’), (‘data_type’, [‘Humidity’, ‘Temperature’])])), (‘0a520200ad010031240269’, OrderedDict([(‘name’, ‘Altan’), (‘data_type’, [‘Humidity’, ‘Temperature’])]))]) for dictionary value @ data[‘devices’]. Got OrderedDict([(‘0a52091bbf0000e0240289_temperature’, OrderedDict([(‘name’, ‘Utomhus’)])), (‘0a5202009e010036480379’, OrderedDict([(‘name’, ‘Krypgrunden’), (‘data_type’, [‘Humidity’, ‘Temperature’])])), (‘0a520201b30100c01a0269’, OrderedDict([(‘name’, ‘Källaren’), (‘data_type’, [‘Humidity’, ‘Temperature’])])), (‘0a520200ad010031240269’, OrderedDict([(‘name’, ‘Altan’), (‘data_type’, [‘Humidity’, ‘Temperature’])]))]). (See ?, line ?). Please check the docs at https://home-assistant.io/components/sensor.rfxtrx/
17-04-09 19:42:17 WARNING (MainThread)

Also UNIFI stoped working, not a big problem but something i need to look at when this above is fixed.
Anyone haveing a idé?

Ok, looks like something was changed to the RFXTRX component?

I needed to remove all the sensors, they i got new once in HA. But they all did have new names.
When i try to add them too my sensors.yaml file i get same error.

Now i have 1 device with the humidity as a attribute, not as a own device.

This is how my config used too look like:
name: Källaren
- Humidity
- Temperature

The same sensor have this name now: 0a52020ead0100a6280069_temperature

How can i make create a new device name for this? And split it in group.yaml for temperature and humidity?

That change was done several releases ago. Check the old release notes.
The rfxtrx sensor has not changed since November https://github.com/home-assistant/home-assistant/commits/dev/homeassistant/components/sensor/rfxtrx.py

Allright! I did work for me yesterday but not today after update :slight_smile:

How do i rename a device? And how do I get the humidity to show in a group?

When i use customize.yaml to change the name of a sensor i get a new sensor with a new name

my yaml code is

  friendly_name: Tvättstuga
  device_class: sensor
1 Like

I still have the same problem that when i add the sensors to my sensor.yaml file i get errors

My config:

    name: Krypgrund
      - Temperature
      - Humidity 

Then I get an error that its a invalid ID for the device. If I remove the config (devices) it shows up with a new device_id. Then I add that ID insted, same error invalid ID, Remove, Reboot HA a new device ID.

What am I doing wrong?