Update to 107.5 fails

All,
I am getting started with Hass.io, first sonoff´s reflashed and up and running through MQTT. With this forum being of great help, browsing through earlier posts.

I am now stuck with the following, when selecting “Update” in supervisor dashboard, I get an error. With the below message in the log.

**20-03-23 12:49:44 ERROR (SyncWorker_13) [supervisor.docker.interface] Can't install homeassistant/raspberrypi4-64-homeassistant:0.107.5 -> 500 Server Error: Internal Server Error ("Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:54959->[::1]:53: read: connection refused").**
**20-03-23 12:49:44 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails**

Error

What did I miss ? Configuration of somethign somewhere ?
Appreciate your help, grtz
John

Hello,
Same issue for me, update from 0.106.6 to 0.107.5 fails with same error message
VM Virtualbox Debian Buster.
Nothing found to solve it

I got this error too today. Second time I tried the update succedded.

Hey same issue for me, update from 0.106.6 to 0.107.5 fails with same error message

20-03-23 19:41:23 INFO (MainThread) [supervisor.homeassistant] Update Home Assistant to version 0.107.5
20-03-23 19:41:23 INFO (SyncWorker_0) [supervisor.docker.interface] Update image homeassistant/qemux86-64-homeassistant:0.106.6 to homeassistant/qemux86-64-homeassistant:0.107.5
20-03-23 19:41:23 INFO (SyncWorker_0) [supervisor.docker.interface] Pull image homeassistant/qemux86-64-homeassistant tag 0.107.5.
20-03-23 19:41:33 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install homeassistant/qemux86-64-homeassistant:0.107.5 -> 404 Client Error: Not Found ("no such image: homeassistant/qemux86-64-homeassistant:0.107.5: No such image: homeassistant/qemux86-64-homeassistant:0.107.5").
20-03-23 19:41:33 WARNING (MainThread) [supervisor.homeassistant] Update Home Assistant image fails

Check the connection to internet, if it jumps for a second, stop automatically the uploading.
In any case, is better upload HA from the CLI with the command “ha core update”, so you can check the status live

Thanks @magik95 - Tried the CLI, but same result (seems our UI is just a frontend to to the CLI commands). My internet connection is superstable, and un-interrupted.

@Dario_Musante Seems your error points in a different direction then my failure ( your “No Such Image” tells me the image for download is not there or at a different location)

When I dig into the error message I get, it feels like I am having a problem with “authority”, as the heart of the matter is a “Connection Refused”. See log extract below. Any guidance or pointing me in the right direction much appreciated !

'20-03-24 08:49:19 ERROR (SyncWorker_12) [supervisor.docker.interface] Can’t install homeassistant/raspberrypi4-64-homeassistant:0.107.5 -> 500 Server Error: Internal Server Error (“Get https://registry-1.docker.io/v2/: dial tcp: lookup registry-1.docker.io on [::1]:53: read udp [::1]:37117->[::1]:53: read: connection refused”). ’

grtz
John

Hi every one,

I try with SSH connection to pull docker image manually :

[email protected]:~$ sudo docker pull  homeassistant/qemux86-64-homeassistant:0.107.5
0.107.5: Pulling from homeassistant/qemux86-64-homeassistant
4167d3e14976: Pull complete 
4afba27d82b3: Pull complete 
bf32c5635d29: Pull complete 
7c5d9695d55c: Pull complete 
9f1a02b7fbec: Pull complete 
d8aa002e4f6f: Pull complete 
e4baab60acce: Pull complete 
065a46d18176: Pull complete 
5e9109177150: Pull complete 
092fd4d6fddc: Pull complete 
24b9e1ac4dc2: Pull complete 
2ce5f74ef8f5: Pull complete 
64510477e867: Pull complete 
7d81b47d1365: Pull complete 
ff2024b98b26: Pull complete 
3516b95ab148: Pull complete 
1d3c26acae4f: Extracting [==================================================>]  288.4MB/288.4MB
709d7ac246f1: Download complete 
e186c73c04c3: Download complete 
d1f92ee467a8: Download complete 
8055c77b3a45: Download complete 
f498f8659b60: Download complete 
failed to register layer: Error processing tar file(exit status 1): mkdir /usr/local/lib/python3.7/site-packages/python_openzwave/__pycache__: no space left on device

the error message becomes very clear : no space left on device !

looking what is too big :

[email protected]:/usr/share/hassio/homeassistant$ ls -l
total 304220
-rw-r--r-- 1 root root         2 janv. 14 16:01 automations.yaml
-rw-r--r-- 1 root root      2347 févr.  5 18:51 configuration.yaml
drwxr-xr-x 2 root root      4096 janv. 14 16:01 deps
-rw-r--r-- 1 root root         0 janv. 14 16:01 groups.yaml
-rw-r--r-- 1 root root      4265 mars  24 07:46 home-assistant.log
-rw-r--r-- 1 root root 311484416 mars  24 10:51 home-assistant_v2.db
drwxr-xr-x 4 root root      4096 mars  12 14:16 node-red
-rw-r--r-- 1 root root         0 janv. 14 16:01 scenes.yaml
-rw-r--r-- 1 root root         0 janv. 14 16:01 scripts.yaml
-rw-r--r-- 1 root root       157 janv. 14 16:01 secrets.yaml
drwxr-xr-x 2 root root      4096 janv. 14 16:01 tts

The Home-assistant data base is realy too big !
I delete it :

sudo rm home-assistant_v2.db

Don’t worry ! Home-assistant will recreate it automatically, but beware ! you lose all stored data :dizzy_face:
Now, there is enough space to update Hassio to 0.107.5

[EDIT]
for more information: Hassio is installed on a VirtualBox VM with 1 GB of ram but only 6 GB of disk, which is insufficient

Gerard

All,
For what it is worth, some additonal info on my setup:

  • RaspberryPi-4 with the hass.io package
  • Supervisor version 209 / Host System HassOS 3.12 Production / Core 0.106.5
  • Update to 0.107.6 fails
  • From CLI, name resolution works (I can ping to www.telegraaf.nl), so assume DNS is OK.
  • Plenty of disk space left (using only 10%)
  • Using the UI, or the CLI ($ ha update core) result in the same error (connection refused), see below extract from the log.

Any thoughts from this community to guide me what I have missed? Or alternative procedurs to get me to 0.107.x ?
tnx
John

I have the same issue

All,
SOLVED (the “connection refused” issue) :
Since my system is still in early stage of setting it up, I decided to go for a fresh install (0.107.6). All went well, and then I noticed that the system log of the maiden installation (the 20 minutes waiting phase) showed two similar events when trying to load packages. The maiden installation then logged a “retry in 30 seconds”, and that load passed after 2nd retry. So far so good. Core 0.107.6 installed and up and running.

I just now noticed there was an update to 0.107.7 available. Using the UI to update, same error message came up. But after waiting for a moment and just retrying, the update simply came through without errors.

So my advice is to just wait and retry a couple of times. It has nothing to do with wrong settings or alike, maybe that central server is too busy or too many parallel connections and then refuses a new connection.

grtz
John

@francisp You got it right …