Update to 2020.12.1 failed

Tags: #<Tag:0x00007fc41eaca078>

Updated the OS to 5.8 and then attempted to update the core to 2012.12.1 and it failed with this error message:

20-12-17 20:48:37 ERROR (SyncWorker_2) [supervisor.docker.interface] Can't install homeassistant/qemux86-64-homeassistant:2020.12.1 -> 500 Server Error for http+docker://localhost/v1.40/images/create?tag=2020.12.1&fromImage=homeassistant%2Fqemux86-64-homeassistant: Internal Server Error ("Get "https://registry-1.docker.io/v2/": net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)").

Not sure what the problem is, but looking at the error I attempted to use a browser to access “https://registry-1.docker.io/v2/” and it failed with the following:

	
errors	
0	
code	"UNAUTHORIZED"
message	"authentication required"
detail	null

Any ideas?

For ongoing discussions see Can't install homeassistant:2020.12.0. Same problem being discussed there.

Try following

1 Like

Great job this works.

It worked! Thank you!

Didn’t help me. I am also running under Proxmox.

What error are you getting?

Same as before, Error 500. If I downgrade the OS to 4.2, all is fine. This is more than a DNS config issue.
Tried upgrading to 2020.12.1 while running 4.2 and it worked fine. Upgraded OS to 5.9. No problems until I tried to install the SSH community add on. That failed (500) and so did the upgrade to 2020.12.2 (500). Verified I had IPv4 set to static and using Google DNS 8.8.8.8. Rebooted, tried again multiple times - failed. Waited 24 hours tried again multiple times - failed. Downgraded OS (again) to 4.2 and was able to install SSH community add-on.

Edit - At this point I’m willing to stick to 4.2 until this gets sorted by the devs.

Update - I upgraded to OS to 5.10 and attempted the update to 2021.1.0 and it failed the first time, but after re-setting the static IP to 8.8.8.8 it succeeded. In addition I just now updated to 2021.1.1 and the update completed. The 5.10 OS had a change to not default to DNS over TLS as it was causing slow performance and timeouts. Not sure if this made the difference, but it worked for me when nothing else would.