Update to 2023.6.2, no web IF afterwards

I updated from 2023.5.4 to 2023.6.2. Update went fine but afterwards I cannot connect to the web UI.

Device can be connected via SSH. Observer says everything is healthy, but I cannot connect to web.

Any advice what I can do ?

The log says following

2023-06-16 08:33:57.064 ERROR (SyncWorker_4) [homeassistant.util.json] Could not parse JSON content: /config/.storage/homeassistant.exposed_entities
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/util/json.py”, line 68, in load_jso n
return orjson.loads(fdesc.read()) # type: ignore[no-any-return]
orjson.JSONDecodeError: Input is a zero-length, empty document: line 1 column 1 (char 0)
2023-06-16 08:33:57.071 ERROR (MainThread) [homeassistant.setup] Error during se tup of component homeassistant
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/util/json.py”, line 68, in load_jso n
return orjson.loads(fdesc.read()) # type: ignore[no-any-return]
orjson.JSONDecodeError: Input is a zero-length, empty document: line 1 column 1 (char 0)
The above exception was the direct cause of the following exception:
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/setup.py”, line 286, in _async_setu p_component
result = await task
File “/usr/src/homeassistant/homeassistant/components/homeassistant/init.p y”, line 346, in async_setup
await exposed_entities.async_initialize()
File “/usr/src/homeassistant/homeassistant/components/homeassistant/exposed_en tities.py”, line 125, in async_initialize
await self._async_load_data()
File “/usr/src/homeassistant/homeassistant/components/homeassistant/exposed_en tities.py”, line 348, in _async_load_data
data = await self._store.async_load()
File “/usr/src/homeassistant/homeassistant/helpers/storage.py”, line 122, in a sync_load
return await self._load_task
File “/usr/src/homeassistant/homeassistant/helpers/storage.py”, line 131, in _ async_load
return await self._async_load_data()
File “/usr/src/homeassistant/homeassistant/helpers/storage.py”, line 149, in _ async_load_data
data = await self.hass.async_add_executor_job(
File “/usr/local/lib/python3.11/concurrent/futures/thread.py”, line 58, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/src/homeassistant/homeassistant/util/json.py”, line 74, in load_jso n
raise HomeAssistantError(error) from error
homeassistant.exceptions.HomeAssistantError: Input is a zero-length, empty docum ent: line 1 column 1 (char 0)
2023-06-16 08:33:57.090 ERROR (MainThread) [homeassistant.bootstrap] Home Assist ant core failed to initialize.

Thanks, Oliver

I have same issue, my logs are cleaner I don’t see any fails to load core. I am actually connected to the core directly, but I can’t connect to web after update.

more info:
I run my install on RP4, on the SSD. Everything was running fine for a year or so. I can connect with monitor and keyboard and see the system running, even some automation (like motion lights) work. But I cant connect to UI not from browser not from the app.
I tried downgrading to lower version that was working, but I still can’t connect. The IP of the HA didn’t change, I can see it in my router settings and I can see it in the HA.

Same problem here after the latest 2023.6.2 core update: web connect impossible
(my RPI4 runs also on an usb ssd)
basically you should be holding your breath on every update and crossing your fingers…
the result will again be a lot of extra work to get it up and running again
I would also prefer to see fewer updates in the future, but then the updates that are there, that they have been properly and thoroughly tested in advance

edit: see also this thread, similar I suppose…

and the comment of user “prj”


Every time I update HA I ask myself, why did I do it? It’s almost always a mistake and ends in tons of wasted time… over the last few years, I think 1 or 2 updates went smoothly and 4 or 5 caused HA to be completely unreachable. Can’t complain about free software of course, but I don’t know any software that has this comical of a track record.



I know it is tempting, to grab every update as they become available.The monthly releases (year.mo.1) are functionality(enhancement) releases, the others (year.mo.2-?) are primarily fixes/cleanup of the monthly release. Only update at the end of the month. If you running a test system go for it (and report problems), if you are running a ‘production’ system, stability is your #1 priority.

1 Like

Same issue with me too. If I try the duckdns url it shows initialising. If I try thorough the direct one it says “Unable to connect to Home Assistant” Retry in x seconds.
I have my HA set at port 8443 and https only.

Does anyone know who to tag in this topic to escalate this?

Have any of you guys hard-restarted HA ? … as it(this update) clearly stated for me, after install(and what seemed to be a restart) a popup stated that i actually had to manually restart HA … so i rebooted, just in case … on the other hand, i dont run PI

in that case it seems like you should update python-version( so check that first )

As said, im not running PI, but Homeassistant OS, so im fine :slight_smile:

Python Version 3.11.4

I am having exactly same problem after update to 2023.6.2. I am using HA OS on the PI. The web UI was stuck in “Unable to connect to Home Assistant”.

If I connect a monitor on the PI, I can see the CLI has been loaded. For the error, I can see Python version 3.11. Any suggestions?

Same for me. I can revert to 2023.5.0 at the CLI of the VM on TrueNAS Scale and WebUI and Android app connect.
The upgrade to 2023.6.x works but Port 8123 is no open.

How do I find out my version of python and how to update it if needed? Never had to do this.