Update to Z-Wave JS- can't see any of my Z-wave devices. Again

I just got a notification to update Z-Wave JS.
Clicked on Update.
Restarted Home Assistant.
Now, none of my Z-Wave devices are online.



What happened?

Please clarify, a notification for Z-Wave JS or Z-Wave JS to MQTT? Your screenshot shows you are configured for zwavejs2mqtt, not Z-Wave JS.

Many users mistakenly run both add-ons at the same time, which will cause problems that can surface when one add-on restarts. Double check you’re not in that state.

This is what I got this morning:

Last week I went through the Z-wave transition following the manual migration instructions because the migration wizard didn’t work.

You can’t run both add-ons with a single USB stick at the same time. That’s likely your problem. Uninstall the Z-Wave JS add-on.

Thanks for the tip.
This is what I get for following the migration instructions. Yes it said to “Remove Zwave 1.4 from HA”, but not to “Uninstall the Z-Wave JS add-on”. Since that step was a bit confusing, I skipped it.

But, I uninstalled Z-Wave JS and clicked on the Z-Wave JS to MQTT update. And, still, all of my Z-Wave devices are unavailable.

Now, what?

Update- I looked at Integrations, and Z-Wave JS is back.


So it’s working then? Or, did you mean Add-on instead of Integration?

Just want to add that I got this as well. z-wave JS only on my system. Everything was working prior to running the update. Now the z-wave JS integration is not working.

I am completely confused. I just want to get my Z-wave devices back. The only, ONLY reason I did the migration was because without it, all of my Z-wave devices were unavailable with an update to HA core.

Z-wave core, Z-wave add on Z-wave JS, Z-wave MQTT. I need a roadmap.

The migration instructions said to "Remove Zwave 1.4 from HA”. Is that the same as “Uninstall the Z-Wave JS add-on”

Did you remove the integration for some reason? What happened to the one configured in your original screenshot?

At this point and after many hours of frustration, I really can’t recall what I’ve deleted now. I am ready to go to a snapshot from before all this happened, but I have a day of ESPHome and Node Red work that would be lost. But at least my Z-wave devices would be online.

I am really going to appreciate some hand-holding here.

FWIW, here is my add-ons page:

Okay, I’ve solved my issue with a complete shutdown of the host, in my case a raspberry Pi 3b. Not sure why it was needed, but maybe this will help. Just to be clear, this wasn’t a restart, this was a complete shut down. I left it down for a few minutes before turning back on. All z-wave sensors are back working as normal.

A host reboot was one of the first things I did. Are you suggestion a power-off restart?

Why do you have 2 zwave addons? If they are both auto start, they will fight for the z stick. You also have to make sure your zwavejs integration is pointing at the correct addon.

I don’t know.

What is the best way to proceed? Should I start over from a snapshot before updating (See Post #3). It was when I clicked on the updates that things got hosed. I was unaware or oblivious to the instructions to remove Z-Wave JS, so you may be correct that the two are conflicted over which has the Z-stick.

My searching for a solution has me more confused. Some say that only one add-on is allowed, and yet others specifically discuss using Z Wave JS but I understood that Z Wave JS was no longer supported. As I said, I just need a roadmap.

So, can you offer things to try before I go back to an earlier snapshot?

Absolutely, yes. I shut down my rpi3 and switched off at the socket. Let it sit for a few minutes then booted up the rpi3 again. Everything came back up as normal.

OK, that will be easy to try, though my HA server is in the basement.
One more detail. I opened the zwave to js mqtt control panel and saw this:

I am no Z-wave expert, but it appears that the Z-wave devices are talking to each other- the “last active” on the controller is only ten minutes ago.

Your roadmap is:

Keep the addon you originally used in the migration and delete the one you didn’t use.

Then check the zwave js integration setup configuration and ensure it’s set up to use the addon you chose.

I don’t have any other details as I don’t have access to anything that allows me to help further.

Thanks guys.
I am making progress here.

I reinstalled the Z-Wave JS to MQTT add-on carefully following the migration instructions.

I think I forgot to uncheck this the first time around, but I am not sure.
Select connection method

My entity names have changed back to the defaults, except for one (??). I renamed the others in the Z-Wave JS to MQTT Control Panel (I only had one Nano device), and restarted HA.

The migration instructions say:

By default the Home Assistant Z-Wave JS integration will try to set up the official “Z-Wave JS” add-on from the official add-on store.

So, do I delete the Z-wave JS add on or not?

Again, thanks. I have made copious amounts of notes for the next time an update does this to me.