Update won't work

When trying to update I get a sudden halt.

Checking current version
Setting correct premissions
Changing to the homeassistant user
Changing to Home Assistant venv
Upgrading Home Assistant
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple

Please can some one tell me what is wrong?

You’re missing to say from what version to what version.

Have you checked all the breaking changes from old version to the new one and adapt your code/components accordingly?

This is the first thing I can imagine

Follow these instructions and try posting again.

Hi Bosborne
I do not understand what you mean. This is a Home Assistant question. Asked questions before and got an answer from all those nice people. Please explain what is bothering you?

Hi Woody,
I was up to date until 0.92.0. I forgot update to 0.92.1 but tried to update to 0.92.2 today.
Than during the update routine it stopped as mentioned.
After ‘Looking in indexes …’ it stops.

Probably, what @anon34565116 meant with his message is, have you searched the forum before posting?

Because I searched and I found an issue very similar to your.

Maybe, you have to read that post and, if necessary, write there.

Tried search but got only different kinds of error. Okay no biggie I search again.

Try to search what is your last message you receive.

In any case I can’t help more than the suggestion I gave you since I’m using Hassio on Docker and I’ve never used the virtual env.

All I can find is really not the same.
Well maybe I am not ready for home assistant.

Looking closely at the first post you are running Venv on an unknown OS moving from an unknown version to an unknown version. You gave a very truncated log with very limited useful information about the error.
You need to learn how to ask a question so we can help you. We are here to help so information on what you already tried to resolve the issue is helpful too.

1 Like