Updated and rebooted HASS, now AppDaemon cant connect to it


Updated hass to 0.90.0. Everything worked for a day then when i rebooted my ServerPC, appdaemon has an auth error.
Tried multiple variation of configs. Doing the old api_key way, making new user with long access token or using my current main user with long access token. neither worked.
Prevously i had:

  ip_ban_enabled: True
  login_attempts_threshold: 5

but i deleted the ip_ban.yaml and disabled this two lines in configuartion.yaml. I can login from the same IP address (with api_key or any user)
I still think login attempt treshold is the problem. Is hass saving that somewhere else?

Heres my configs:


  # api_password: !secret api_password
  ssl_certificate: '/etc/letsencrypt/live/g/mydnsaddress.com/fullchain.pem'
  ssl_key: '/etc/letsencrypt/live//mydnsaddress.com/privkey.pem'
  base_url: https://mydnsaddress.com:8123


  app_dir: /home/myusername/.homeassistant/conf/apps
  threads: 10
  # time_zone: <time zone>
  # api_port: 5000
  # api_key: !secret api_password
  # !secret api_password
  # token: !secret login_appdaemon_token
  api_ssl_certificate: '/etc/letsencrypt/live/mydnsaddress.com/fullchain.pem'
  api_ssl_key: '/etc/letsencrypt/live/mydnsaddress.com/privkey.pem'
      type: hass
      ha_url: 'https://mydnsaddress.com:8123'
      # ha_key: !secret api_password
      token: !secret login_appdaemon_token
      # cert_verify: false
      namespace: default

Wheres my fuck up? Please help me, i need my “follow me around” house lights :slight_smile:

You might try moving the line

 api_password: !secret api_password

I put it under “auth_providers:”
That allowed me to run HASSIO after 9.0 borked mine last night.
Mine prolly isn’t right, but HASSIO ran after ssh reboot.
This what mine looks like now:


  • type: legacy_api_password
    api_password: !secret http_password
  • type: homeassistant
  • type: trusted_networks
    • ::1
    • fd00::/8

I now plan ahead to spend 4 hours every time I update, I think the last 4 updates broke my front end every time.
Looks like 90.1 is scheduled to brake the legacy api. I am frantically looking for updated instruction before breaking it again. This link was miraculously updated and shows how to run 90.0 Authentication providers - Home Assistant

Some ssh commands that have been helping me update and recover are:
hassio ha check
hassio ha restart
hassio sn reload
hassio ha stop
hassio ha update
hassio ha info

Good luck Man!

1 Like

Thanks man! You actually pushed me the right direction.

    - type: legacy_api_password
      api_password: !secret legacy_api_password
    - type: homeassistant

Its indeed very scary to update and im here since 2016 :slight_smile:
Sometimes the tradri gateway psk key breaks after hass updating and just fixes itself after 6 hours of debugging. You can never know.
Thanks again. Marked as solved.

1 Like

Looks like they break legacy_api_password for good in 90.1
I’m gonna hold off on 90.1 till I get successful reboots after removing legacy_api_password.


Long-lived tokens supposed to work with appdaemon, but not for me atm :confused:

1 Like

Is ssl working?
edit: never mind, dont install appdaemon with hass in the same virtual environment