Updated to 0.88.0 and got "custom element doesn't exist"

I am using this in my ui-lovelace.yaml:

  - url: /customcards/lovelace/card-tools.js
    type: js
  - url: /customcards/lovelace/card-modder.js
    type: module
  - url: /customcards/lovelace/secondaryinfo-entity-row.js
    type: module
  - url: /customcards/lovelace/monster-card.js
    type: js
  - url: /customcards/lovelace/fold-entity-row.js
    type: js
  - url: /customcards/lovelace/useful-markdown-card.js
    type: js
  - url: /customcards/lovelace/bignumber-card.js
    type: js
  - url: /customcards/lovelace/time-input-row.js
    type: js
  - url: /customcards/lovelace/tracker-card.js
    type: js
  - url: /customcards/lovelace/alarm_control_panel-card.js
    type: js
  - url: /customcards/lovelace/mini-media-player-bundle.js
    type: module
  - url: /customcards/lovelace/compact-custom-header/compact-custom-header.js
    type: js
  - url: /customcards/lovelace/kiosk.js
    type: js

and e.g.

- type: custom:card-modder
    type: custom:useful-markdown-card
    content: >
      # [[ sensor.date_short ]]

      ## [[ sensor.swedish_calendar_weekday ]] vecka [[ sensor.week_no ]]

After upgrading to hass.io 0.88.0 today I get the custom element doesn't exist: card-modder error. Worked like a charm right before the upgrade.

What should I check?


Have you updated the card-modder?


Just updated everything with the updater-card, maybe need another restart.

Gör det! Think the changes needs a reboot to HA to read the JS files.

It works now, must have been some card that was not updated.

Tack för hjälpen! / Thanks for the help!

Just in case anyone with similar problems reads this:

If the card uses card-tools, the solution is to update card-tools

If that doesn’t work, clear the cache.
If that doesn’t work, make sure you really did update card-tools. Compare line 15 of the source code to what’s on github.
There’s a 110 % probability that card-tools is your problem.


Similar problem with different cards though.

I’m having the same problem. I confirmed card-tools is up to date and so is card-modded. I also checked on all browsers, cleared cache and also getting errors on iOS app. I’m stumped. It worked prior to going to 0.88.0.

UPDATE: a separate reboot after the upgrade fixed my problem.

I’m sorry if I missed something, but I get this error after the update to 88.1:

Log Details (ERROR)

Sat Feb 23 2019 08:36:30 GMT+0100 (Centraleuropæisk normaltid)

http://xxx.xxx.xxx:8123/local/card-tools.js?v=445b68:19:12 Uncaught TypeError: Cannot convert undefined or null to object

I dont see any updates in my custom card, but should. I manually update something?

I’m curios… What custom alarm are you using since you can have it in your custom updater?


I thought I would share if you are here because you are having an issue with your ios device and that a card is throwing this error message on your iphone or ipad.

I ran in to issues after i had installed the card wrong when accessing the app on my ipad. I cleared the cache in the settings of the device and the card worked as intended.