Updated to HA OS 6 z-wave issue AGAIN! Controller status: Driver: Failed to initialize the driver: Timeout while waiting for an ACK from the controller

Just updated and HA OS 6 and now am getting this message: Controller status: Driver: Failed to initialize the driver: Timeout while waiting for an ACK from the controller. I don’t know what do to now… has anyone had the same issue?

Yes same here

For me HA OS 6 it is ok with z-wave. I remember had an equal issue last year. HA OS changed the name of the serial device. Check your configuration. Does supervisor → system → hardware ->/dev/ttyACM0 or → /dev/ttyAMA0 fit your z-wave config in /config/configuration.yaml (or other z-wave controller)? Hope it helps.

1 Like

I don’t have a z-wave config in /config/configuaration.yaml… if it has changed… how do i update the config if i don’t have it in my configuration.yaml folder?

Nothing apprars in the ZWave to MQTT after upgrading to HAOS 6.1

You use Z-Wave Js to MQTT:

Look there how to integrate your Z-Wave dongle.

thanks but I am looking for a solution, not be to redirected to another resource. Can you help with a solution?

hmmmm… you want me to read the documentation for you :thinking:


Possible solution from the docs (hardware: read posts before):
To do this:

Open the Z-Wave JS to MQTT control panel by clikcing the "OPEN WEB UI" button on the add-on page in the Supervisor.
In the control panel, go to "Settings" in the menu and click on the "Zwave" bar that shows up on the right.
Enter the following information:
    Serial Port (e.g., /dev/serial/by-id/usb-0658_0200_if00)
    Network Key (e.g., 2232666D100F795E5BB17F0A1BB7A146)

Now click the “SAVE” button and navigate to the “Control Panel” in the menu. If you had devices paired already, you should see the showing up slowly.

No this does not work. it appears this issue is widespread

Same happened to me without any OS update (2022.03). I use Z-wave JS to MQTT and Zigbee2MQTT and suddenly all my devices went offline. I checked hardware info and realized that ttyUSB0 and ttyUSB1 swapped for my dongles. So I changed the config accordingly and it’s working now. Soooo strange for me…

1 Like

Ugh. I had this happen when I recently updated HAOS. I wasted most of an afternoon chasing it down. It started with my alarm system losing communication. I didn’t put two and two together until I realized my Z-wave devices were also down.