Updates do not show on configuration page

I believe it started with core 2022.4.0, I am now at 2022.4.7. I had first noticed when I saw on the system tab there was an update. I had to use the cli in order to update to 2022.4.6 and the same for .7.

Today I’m seeing that there are updates for my addons, they are also not showing at the top of the configuration page. Is there some way that I could have disabled this by accident?

Are your user an admin?
Do you run in advanced mode?

Not sure if that could do it, but it is just the two option in HA that I could think of might have an effect like that.
Other than that I would probably try to delete the browser cache on you client.

My user is owner. It does it on multiple machines/browsers. When a core update is available, I think there was an upgrade button that showed on the system tab, that doesn’t show. My only option for that is the command line.

The addon’s show a bar at the top and I am able to upgrade them on their store page.

image

Edit: Advanced mode was/is on the general tab? I don’t see it as an option. I see it under user, it’s enabled.

In my setup I get following reminders.

  • number in a light blue boble in the Configuration field in the sidebar
  • an extra field at the top of the configuration menu

That’s what I used to get as well but just stopped appearing one day.

Ok, then I am at a loss.

Have you installed core 2022.5.1? On the new update page, do you get this message if you click the refresh icon on the right?

image

Is your system supported and healthy?

It is

Strange. If you go to your list of integrations, do you see Hassio (or Home Assistant Supervisor) in the list and enabled? That’s what creates and manages the update entities HA shows there. That’s the only way you could disable this feature that I’m aware of.

1 Like

That was it, for some reason all the entities under core, supervisor, and haos were disabled. Once enabled 2022.5.2 showed where it should.