Updating docker container to 0.107 is failing

So I pulled the latest docker image and the container is failing to start because it seems that the entrypoint script is missing:

[FATAL tini (6)] exec /bin/entry.sh failed: No such file or directory

I took a look inside the image and saw that indeed the script is missing. Was this changed in 0.107 or something, or was it just a mistake in the creation of the image? I don’t really know if I should just copy the script from the old image into the new one - or how to do it, really.

Same thing happened. It seems the docker container has changed and doesn’t use that entry point, but portainer seems to cache it.

Change the entry point to /init in portainer and restart that container and it should come up

1 Like

entrypoint instruction has changed, has to be changed to /init

Thanks, that did the trick!

Actually try leaving it blank, with /init specified I had dual instances starting.


Or you can just remove the container using Portainer and then re-create it again using your original docker run command.

I couldn’t figure out where to edit that entry so I just removed and re-created it and it works fine.

Thank you for the question - this took me some googling and trying.
Can this be posted as a breaking change on the docker installation (update) instructions?

That always works too :wink:

To remove it click on duplicate/edit.

1 Like

Welcome to the community - but you will realize this project moves quickly and breaks a ton of stuff in the name of progress. The community liaison has already said it’s not a HA issue and to blame Portainer which is pretty much the status quo.


I totally missed the “edit” part of that box.

That is because it is portainer’s fault.

Yes, but unfortunately the docker image was changed without any mention in any of the release notes, which triggered the issue with an upgrade process in Portainer that has worked since the docker images began being published…

No point reading the release notes if they are incomplete and leave out such details.

Where here does it say to use an entrypoint? https://www.home-assistant.io/docs/installation/docker/

It doesn’t but I believe it creates that based on the image it installs.

I never created an entry point to use when I originally started running HA on docker but mine had the entry point in the portainer config nonetheless. I just removed my original container and the old images and re-created it from scratch using my original docker run command and it automatically changed the image entry point config to /init/.

It is a Portainer caching issue but I still think it should have been included in the release notes since it prevents a large number of people from doing an upgrade without knowing that information.

Mine was actually upgraded by ouroboros, so it’s not really exclusive to portainer. Although I had the same issue when I tried to fix it with Portainer.