Updating HA Core from 2022.6.7 (to 2022.7.6) not working

I am having a challenge to update HA Core from 2022.6.7 (to 2022.7.6).
Update seems to start normally but never finishes.
I tried the update through the GUI and also with ‘ha core update’ through the SSH add-on.
What info can I provide to shed some light on the situation?


Go into Logs and look at the errors. Anything related to the update?
If not, in the Logs-screen, select SUPERVISOR from the pull-down menu on the top right. And look again for a related error.

I’m seeing the same issue, although I’m running 2022.7.0 currently. Here’s what the Supervisor log ends up with:

22-07-25 13:38:27 ERROR (SyncWorker_4) [supervisor.docker.interface] Can't install ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.7.6: 404 Client Error for http+docker://localhost/v1.41/images/ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.7.6/json: Not Found ("no such image: ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.7.6: No such image: ghcr.io/home-assistant/raspberrypi3-homeassistant:2022.7.6")
22-07-25 13:38:27 WARNING (MainThread) [supervisor.homeassistant.core] Updating Home Assistant image failed

Only thing I can remotely find is:

Logger: homeassistant.helpers.event
Source: components/dhcp/__init__.py:155
First occurred: 11:23:01 AM (1 occurrences)
Last logged: 11:23:01 AM

Error while processing event <Event state_changed[L]: entity_id=device_tracker.lgwebostv, old_state=None, new_state=<state device_tracker.lgwebostv=home; source_type=router, ip=--, mac=48:8d:36:52:c0:bc, icon=mdi:help-network, friendly_name=48:8d:36:52:c0:bc @ 2022-07-25T11:23:01.119127-07:00>> for domain device_tracker
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/event.py", line 415, in _async_dispatch_domain_event
    hass.async_run_hass_job(job, event)
  File "/usr/src/homeassistant/homeassistant/core.py", line 544, in async_run_hass_job
  File "/usr/src/homeassistant/homeassistant/components/dhcp/__init__.py", line 311, in _async_process_device_event
  File "/usr/src/homeassistant/homeassistant/components/dhcp/__init__.py", line 331, in _async_process_device_state
    self.async_process_client(ip_address, hostname, _format_mac(mac_address))
  File "/usr/src/homeassistant/homeassistant/components/dhcp/__init__.py", line 155, in async_process_client
    made_ip_address = make_ip_address(ip_address)
  File "/usr/local/lib/python3.9/ipaddress.py", line 53, in ip_address
    raise ValueError('%r does not appear to be an IPv4 or IPv6 address' %
ValueError: '--' does not appear to be an IPv4 or IPv6 address

@TammoHeeren your error is probably about something else.

You should check the SUPERVISOR-log, I would expect any error related to updating to be there.
As @jHA86 is showing.

Update: @TammoHeeren you should probably check the SUPERVISOR-log from the command-line (supervisor logs or something similar), just after you have tried updating.

Are any of you out of disk space?

I just tried this update and it just hung, never finished.
Still shows the update being available. I think I will stay away from updates for a while…don’t want to break it.

Working for the rest of us :slight_smile:

Tried it again and its working. Must have fixed itself. Gremlins in the system.

After way too much banging my head against the wall, a full reboot of the host system resolved the issue and allowed the update to complete successfully. Turns out the “404” error was misleading, and actually the Supervisor had lost Internet access. The reboot resolved that.

Plenty of disk space left. 4.9 GB free

Nothing in the supervisor logs aside from some Zigbee2MQTT warnings.

I am getting also a bunch of other ERRORs now related to other things with sqlite, saving files, etc. I have a suspicion that that is probably my flash card giving out. I was able to install other things and make a few backups of the working system.
What is the recommended way of restoring a backup onto a new flash drive? Any instructions I can follow?

You get the opportunity to restore a backup during onboarding.

This turned out to be a SD card issue, and replacing the card fixed the error.