Updating HA Core to 2024.7.0 has been running for 4 hours and still going?!

I assume something has failed, but the spinner keeps spinning anyway. I don’t see anything to do with updates in the logs (not that I know what I’m looking for!)

Not sure what to do about it? If I reboot could I do damage?

Hi, did you install the beta or was the official version released before the live stream?

The official one that was offered in the UI? Never tried the beta.

Do you have a backup?
If nobody steps in to help with this issue, you could stop this process, refresh your browser/restart HA and see how it goes, if possible try to run the update again or do a clean install from the latest version and restore your backup.

Sorry, can’t give you any other advice.

:rofl:

Yeah. Here goes …

If you make it back, you can check things out and upgrade/downgrade from the terminal.

Updated my 2 HA instances without issue.

Sorry, of topic in this thread.

Your system in recovery mode. Login to http://ip:8123 and resote from last backup.

Hi I have similar issue after upgrading core to 2024.7 my HA stooped working, port :8123 stooped responding. I downgraded version in console

ha core upgrade --version 2024.6.2

but it still don’t work. When I do:

ha core restart

it processing it for a long time and end up with error:

Error: No Home Assistant Core response, assuming a fatal startup error

port:4357 works fine
I use raspberry Pi 5

I found the issue… One of my banded ip didn’t have

banned_at

parameter and it cause HA to crash… it is so stupid why it is even necessary…

No idea why, but updating from ha command line (ha core update) seems to have worked ¯_(ツ)_/¯

Sometimes it’s better not to ask why and just be happy.

It’s solved, fantastic!

Now, before you go… please take the time to mark the solution as the answer, you do that by selecting the three dots under the post:

image

Then select the check box:

image