Upgrade error - Cryptography module

Anyone else having this issue? Trying to upgrade form 0.108.9 to 0.109.6 on debian 10 buster on a raspberry pi 3+ using virtualenv , Python 3.7.3, and getting this…

Collecting cryptography==2.9                                                                                                                                                                                                                      [17/56]  Using cached cryptography-2.9.tar.gz (517 kB)                                                                                                                                                                                                            Installing build dependencies ... error                                                                                                                                                                                                                  ERROR: Command errored out with exit status 1:                                                                                                                                                                                                            command: /srv/homeassistant/bin/python3 /srv/homeassistant/lib/python3.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-f4za0l_u/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'setuptools>=40.6.0' wheel 'cffi>=1.8,!=1.11.3; platform_python_implementation != '"'"'PyPy'"'"''                                                                                                                                        cwd: None                                                                                                                                                                                                                                           Complete output (44 lines):                                                                                                                                                                                                                              Traceback (most recent call last):                                                                                                                                                                                                                         File "/usr/local/lib/python3.7/runpy.py", line 193, in _run_module_as_main                                                                                                                                                                                 "__main__", mod_spec)                                                                                                                                                                                                                                  File "/usr/local/lib/python3.7/runpy.py", line 85, in _run_code                                                                                                                                                                                            exec(code, run_globals)                                                                                                                                                                                                                                File "/srv/homeassistant/lib/python3.7/site-packages/pip/__main__.py", line 26, in <module>                                                                                                                                                                sys.exit(_main())                                                                                                                                                                                                                                      File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/cli/main.py", line 73, in main                                                                                                                                                          command = create_command(cmd_name, isolated=("--isolated" in cmd_args))                                                                                                                                                                                File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/commands/__init__.py", line 104, in create_command                                                                                                                                      module = importlib.import_module(module_path)
    File "/usr/local/lib/python3.7/importlib/__init__.py", line 127, in import_module
      return _bootstrap._gcd_import(name[level:], package, level)
    File "<frozen importlib._bootstrap>", line 1006, in _gcd_import
    File "<frozen importlib._bootstrap>", line 983, in _find_and_load
    File "<frozen importlib._bootstrap>", line 967, in _find_and_load_unlocked
    File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
    File "<frozen importlib._bootstrap_external>", line 728, in exec_module
    File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/commands/install.py", line 24, in <module>
      from pip._internal.cli.req_command import RequirementCommand, with_cleanup
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/cli/req_command.py", line 16, in <module>
      from pip._internal.index.package_finder import PackageFinder
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/index/package_finder.py", line 21, in <module>
      from pip._internal.index.collector import parse_links
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_internal/index/collector.py", line 14, in <module>
      from pip._vendor import html5lib, requests
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_vendor/requests/__init__.py", line 114, in <module>
      from . import utils
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_vendor/requests/utils.py", line 25, in <module>
      from . import certs
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_vendor/requests/certs.py", line 15, in <module>
      from pip._vendor.certifi import where
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_vendor/certifi/__init__.py", line 1, in <module>
      from .core import contents, where
    File "/srv/homeassistant/lib/python3.7/site-packages/pip/_vendor/certifi/core.py", line 12, in <module>
      from importlib.resources import read_text
    File "/usr/local/lib/python3.7/importlib/resources.py", line 11, in <module>
      from typing import Iterable, Iterator, Optional, Set, Union   # noqa: F401
    File "/srv/homeassistant/lib/python3.7/site-packages/typing.py", line 1357, in <module>
      class Callable(extra=collections_abc.Callable, metaclass=CallableMeta):
    File "/srv/homeassistant/lib/python3.7/site-packages/typing.py", line 1005, in __new__
      self._abc_registry = extra._abc_registry
  AttributeError: type object 'Callable' has no attribute '_abc_registry'
ERROR: Command errored out with exit status 1: /srv/homeassistant/bin/python3 /srv/homeassistant/lib/python3.7/site-packages/pip install --ignore-installed --no-user --prefix /tmp/pip-build-env-f4za0l_u/overlay --no-warn-script-location --no-binary :none: --only-binary :none: -i https://pypi.org/simple -- 'setuptools>=40.6.0' wheel 'cffi>=1.8,!=1.11.3; platform_python_implementation != '"'"'PyPy'"'"'' Check the logs for full command output.

Found a similiar issue in this post

tip worked, just had to:

pip uninstall typing

but during installation got a new error, but it seems installation was sucessfull
ERROR: hass-nabucasa 0.34.2 has requirement pytz~=2019.3, but you'll have pytz 2020.1 which is incompatible

Don’t know if it can be safely ignored or not.

1 Like

This worked for me. I got these errors:

ERROR: hass-nabucasa 0.34.1 has requirement pytz~=2019.3, but you'll have pytz 2020.1 which is incompatible.
ERROR: aiohomekit 0.2.37 has requirement zeroconf[ip]<0.25.0,>=0.24.4, but you'll have zeroconf 0.25.0 which is incompatible.

I’ve done:

pip3 uninstall pytz
pip3 uninstall zeroconf
pip3 --upgrade --force-reinstall homeassistant

And everything is correct. Thanks!!!