Upgrade from 0.43.2 to 0.45 failed

I just tried to update my AIO installation but it failed totally.

Installing collected packages: voluptuous, requests, async-timeout, astral, homeassistant, multidict, yarl
  Found existing installation: voluptuous 0.9.3
    Uninstalling voluptuous-0.9.3:
Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/shutil.py", line 522, in move
    os.rename(src, real_dst)
PermissionError: [Errno 13] Permission denied: '/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/voluptuous-0.9.3.dist-info/DESCRIPTION.rst' -> '/tmp/pip-aw3ywtdf-uninstall/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/voluptuous-0.9.3.dist-info/DESCRIPTION.rst'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/commands/install.py", line 342, in run
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/req/req_set.py", line 778, in install
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/req/req_install.py", line 754, in uninstall
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/req/req_uninstall.py", line 115, in remove
    renames(path, new_path)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/site-packages/pip/utils/__init__.py", line 267, in renames
    shutil.move(old, new)
  File "/srv/homeassistant/homeassistant_venv/lib/python3.4/shutil.py", line 535, in move

I just upgraded my AIO from 0.43.2 to 0.45.0, following the standard instructions. I’ve had no issues.

That you’re seeing Permission denied suggests that you’re not running the commands as the right user.

@Tinkerer are you also using Zwave? See some people having issues with this part and curious to see if yours went well

Yup, I’m using ZWave.

@Tinkerer I’m having the same issue. - using ZWave also.

That error is a file ownership issue. Are you remembering to run the upgrade as the HA user?

@Tinkerer I’m using Hassbian

Well, this thread is about AIO issues :wink:

However, if you’re getting exactly the same error, that doesn’t matter. The AIO and Hassbian upgrade instructions are basically the same - both involve activating the virtual environment and running the upgrade as the homeassistant user. Are you remembering to do that?

@Tinkerer my apologies. I am back up - it just took longer than most other upgrades.

Cool, so it wasn’t the same error then :stuck_out_tongue_winking_eye:

Yeah, due to the upgrade for OpenZWave I found it took about 20 minutes. The trick is to watch the logs (using journalctl -f -u home-assistant most likely) so you know what’s going on.

You are correct, it was early in the morning and I used the wrong instructions without noticing it.
Works fine now, thanks =)