Upgrade from 0.81.2 to 0.87.1 lost all config

I currently running HASS 0.81.2 with many configuration devices an automation jobs.(xiaomi, hue, Somfy, Orvibo, Iphone) It just works like a charm.
I update to 0.87.1 and after the reboot all of my config is gone, no devices, no automation, no config. only the add-ons worked (duckdns, samba).
I tried restoring parts of the snapshot, but I cant get my config back.

I only could do a full restore to 0.81.2 to get it all back.

Please advise me how to updat to 0.87.1

not good. are you able to SSH into your HASSIO?

If so, then this page might help. there is a command line to install a specific version.

haven’t tried, but 0.87.1 works but it doesn’t have my automation jobs or devices. even when i do a “check config” the gui say the configuration.yaml file isn’t there. but when i check via samba, all files are there.

hmmm… sounds like an incomplete upgrade?
If you look at the link I shared, there are also setup check command lines which might be good to execute to see if the check is failing or not.

i think you mean “hassio homeassistant check”

Thats indeed the one I referred to.

it says “oke”

Hmm… In any case it might help to migrate back to an older version again. That might restore the required files.
If not, then a clean install and restoring a backup might be the ultimate resource…
Sorry 'bout that… wouldn´t know what else would work.

have you checked the home-assistant.log file for errors?

yes, nothing there.
I currently running at 0.82.1 when I ugrade to 83.3 my xiaomi automation jobs dont work, but they are still there.
When i upgrade to 0.84.6 all devices and automation jobs are gone