Upgrade from 1 year old HA version fails. Please help best way to upgrade

Hi All,

Was stuck in a different country for over a year due to COVID without being able to go home…
Now that I had returned, the version of HA have dramatically changed.

I am on Raspberry Pi 3
I am currently running: core-0.106.2
uname -a output : Linux core-ssh.local.haas.io 4.4.50 #2 SMP Sun Sept 17 UTC 2017 armv7l linux

When I tried to upgrade from the Haas GUI. nothing happens. Even I see on the gui that the latest version is available, but clicking upgrade does not work.

I went to CLI as I had SSH plugin installed and configured.

Based on the some other posts here I tried to separately update the OS and also update the core… Both commands failed.

running: ha os update
output: HassOS.update blocked from execution, no Home assistant OS available

running: ha core update
output: HomeAssistantCore.update blocked from execution, system is not healthy

I thought I need to upgrade to some earlier version first and tried to upgrade to version 1.0.0b6 which is almost a year old.

Also did not work with the same error message" system is not healthy"

Please help to understand what my potential issue is?
And what is my best path to upgrade to the latest version?

Is it possible sd card is bad?

New install may be easiest if you only have a few devices

Have you tried to fully power down your rpi, boot up and then upgrade? I remember having similar issues around those HA version numbers and that fixed it for me.

Yes, Have done complete reboot, also complete restore of the SD card and also separately just the supervisor container restart… Nothing worked.

SD card is OK as it is new . Also, system is working fine in the old version… so all my lights and motion detection scripts still operate on the old version… I just can’t upgrade.

I have may scripts in the current installation, but I may just bite the bullet if I find no solution within a day or two and do a brand new install. still hope I can upgrade.

Have you tried this:

  1. Make full backup of your existing installation without password on usb-stick or some where else
  2. Make fresh install of ha with newest version on new sd card
  3. Import your backup of old ha

best regards,

did not try this yet. You mean create a full snapshot?


I had similar issue with my homeassistant running in vm.
So I made a full snapshot, installed a new vm with new version of ha and imported my snapshot.

You can import the snapshot in the beginning of the installation process.

Hope it works for you.

Best regards,

The easiest solution would be to start with a fresh install as suggested already.

Make a snapshot, backup all files also (everything in the config directory including hidden folders like .storage) and keep the current SD as a working backup.

Flash the latest HA OS to a new SD card and copy back your snapshot to restore. The biggest issue you will face is a years worth of breaking changes that you will need to work through. Depending on the complexity of your install, this could be quit the process and may take some time (and lots of reboots).

1 Like

Yes, I wound up rebuilding from scratch… I had quite a few automations and scripts. none of this works or even configured now. Lots have changed in 1.5 years and it almost feel like I have to learn everything from scratch… Oh well, I guess knowledge refresh is not a bad thing…

thank you all for help!