Upgrade homeassistant (hass.io) 32 bit to 64 bit

Hi all,

I got a generic Linux docker installation of hass.io running on my pi 4 for quite some time. It is the 32 bit version as it was recommended at installation time.

I installed docker on buster and then did the generic Linux install version.

To upgrade to 64 bit version can I just replace the home assistant core container somehow or do I have to reinstall from scratch? Someone did an upgrade from a similar setup?

Best regards,

Generic Linux install? What makes you think it was 32 bit? I didn’t know there was such a thing. Did you deliberately install anything but amd64? Are you sure you arn’t running HassOS 32 bit?

Seems there is 32 bit version. @DavidFW1960
To switch from one image to another.
Need to create a backup, save it outside of hassio, then remove the old containers and install the new 64bit one using the install script.
Afterward restore the backup.

1 Like

You can do a generic linux install on a pi too. I run my HA’s on dietpi.

1 Like

That’s really interesting !
Last time I looked Buster was only available in 32 bit and ‘I assume’ you can’t install a 64 bit dockerised Hassio Home Assistant onto that.

Francis, is there an install guide to get dietpi boot from sd but run system from ssd like you can with raspbian buster ?

It is built-in dietpi. Dietpi has a utility called dietpi-drive_manager. You select your SSD, and simply select ‘move root to this disk’


1 Like

Sorry but I didn’t think the pi4 eft supported usb boot as yet.
So is this ‘like’ the raspbian ‘workaround’ that loads the ssd after the sd boot ?

Your terminology suggests different :man_shrugging:

It still boots from sd, only the root is moved to the SSD

1 Like

I just have to say, the reason I like this is, that it might just kill 3 birds with 1 stone.

Apparently vsc (according to sparkydave) can now run on a 64 bit OS on arm processors
(I currently just use my workstation to run vsc from, not sure of the pros and cons between the two, but this gives me options)
And as above it allows you to use an ssd on a pi4

Very good to know until rpf sort the eft out and HA can move forward with a 64 bit ssd image :+1:

Edit: Currently (2020-03-02) the dietpi rpi image is 32bit only

That seems like a good solution. Thanks for the suggestion.

@DavidFW1960 Yep I am running the 32 bit version for the raspberry pi 3 on buster. I have some other utilities running on that pi so Hass os was not an option… I like the idea of the supervised addon system though, so I installed the supervisor and home assistant core manually.

I didn’t realize there was a 32bit build. I ran the 64bit version with stretch before I got my NUC

Having difficulties with dietpi,

I downloaded, etched, plugged in sd, ssd, z-wave stick, network cable - And then power supply (official USB C 3A rated)

Pi Boots, wait till ip appears on scanner, connect via SSH

Go to config, change passwords, set minimal options, go to drive manager, select, format, set mount point, mount, run speed test (write 81mbs, read 241 mbs), change host name, reboot - The Pi does not come back up.

I’ve tried various options, no software, just docker on exit it tries upgrade & fails. Tried internet - Sucess ! Tried sending error report & fails, Tried disabling IPv6 - No difference

EDIT: New - comes back up but does not respond to SSH