Upgrade problem, hassio from 0.82.1 to 0.84.3

Pretty new to HASS and loving it! First time having issues with an upgrade.
Have tried a few times now and gone back to latest backup everytime.
My list of entities is completely empty after upgrade is done. /dev-state in browser.
I have no error messages in logs, only error i get is:
Unable to load the panel source: Error: Loading chunk 46 failed. This error from chrome directly after upgrade/reboot.
Lovelace shows the red text for all entites, but it loads.

I have read around to try to find a solution but i can’t find anything that seems to fit with my error.

df -h says on overlay 22% used. on /dev/root 100% used, but it was the same before upgrade and everything was working. /dev/root isn’t very big either so i don’t think this is the reason for entities to not load.

Hoping for a hint or suggestion how to proceed. going back to 0.82.1 for now. :frowning:

Thanks in advance for any help.

Did you go through the release notes and read about the breaking changes?

Yes, but i did not relate to my error.
Probably i don’t understand what i should look for?

Could you give me a hint what to look for so i can read it again?

Thank you!

You look at the breaking changes in the release posts, and find components that you run that would be listed in those breaking changes.

I might also add if you are refering to lovelace news that i have lovelace on yaml config. And it works, it’s just that all entities are gone.
I use zwave, telldus, manual sensors, yr, smhi, and many more connections which would give me different entities in list under dev tools.
But after upgrade the list is completely blank.
So i don’t understand what to look for in breaking news for both 0.84 or 0.83 that could cause this.

If you are refering to the part that says improved state restoring i can’t find what i should do with that to fix my problem? Perhaps i am stupid but i would love some more detalied help since the text in breaking changes does not explain what i should do.
Might this mean that i need to remove the file /config/.storage/core.entity_registry or do something with this?

Thanks again!

The first place to start would be looking at the actual log file, and not Chrome or Web GUI log. It sounds like it’s just not starting up all the way.

I have no errors in system log as i mentioned in my main message. only the normal “info” rows with data i understand. I get the up and running message.

System log:

18-12-18 19:23:28 INFO (MainThread) [hassio.homeassistant] Updated Home Assistant API token
18-12-18 19:26:14 INFO (MainThread) [hassio.homeassistant] Update Home Assistant to version 0.84.3
18-12-18 19:26:14 INFO (SyncWorker_7) [hassio.docker.interface] Update Docker 0.82.1 with homeassistant/raspberrypi3-homeassistant:0.84.3
18-12-18 19:26:14 INFO (SyncWorker_7) [hassio.docker.interface] Pull image homeassistant/raspberrypi3-homeassistant tag 0.84.3.
18-12-18 19:29:16 INFO (SyncWorker_7) [hassio.docker.interface] Tag image homeassistant/raspberrypi3-homeassistant with version 0.84.3 as latest
18-12-18 19:29:16 INFO (SyncWorker_7) [hassio.docker.interface] Stop homeassistant/raspberrypi3-homeassistant Docker application
18-12-18 19:29:47 INFO (SyncWorker_7) [hassio.docker.interface] Clean homeassistant/raspberrypi3-homeassistant Docker application
18-12-18 19:29:47 INFO (SyncWorker_7) [hassio.docker.interface] Cleanup Docker images: [‘homeassistant/raspberrypi3-homeassistant:0.82.1’]
18-12-18 19:29:55 INFO (SyncWorker_4) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.84.3
18-12-18 19:30:35 INFO (MainThread) [hassio.homeassistant] Detect a running Home Assistant instance
18-12-18 19:30:35 INFO (MainThread) [hassio.homeassistant] Successful run Home Assistant 0.84.3

Home assistant log:

Log Details (WARNING)

Tue Dec 18 2018 20:30:15 GMT+0100 (centraleuropeisk normaltid)
Database is about to upgrade. Schema version: 6

And my entities list is like this:

Current entities

Entity State Attributes
Filter entities Filter states Filter attributes
No entities

This is all the log data i can find.
Is there some more i should know about?


If you don’t care about device/state history, you can try deleting the db file and see if it gets recreated. It appears as though it is trying to upgrade the db schema but it never completes? Just graspin straws here.

I’ll move it into an temp directory and see how HASS reacts.
I’ll post again when i tried this, along with reboot and some thime for HASS to work.


Ok, so i still have the same problem with entities not showing.
BUT, automations seem to work?
So the entities seem to be there, just not showing in dev-tools state or, lovelace or /states in my browser.

So i can only guess it has to do with the breaking news part, improved state restoring??

I still don’t understand how it is supposed to work now? and how i can work with entities in the future when i am changing something.

I can confirm that my entities are all where they are supposed to be.

Try clearing the cache on your browser for your HA site, or try using a different browser to test.

Tried Firefox = same problem as Chrome, IE = did not load text, just colors so could not confirm, Edge = same problem as Chrome.

I am considering deleteing files in /config/.storage/ to see what happens when i do that. would that be helpfull in any way to try? Or is it a waste of time?

You can try that. It will make you reconfigure your password so if you have anything linked with long lived tokens, those will have to be reconfigured as well.

Ok so it worked.

Solution: /config/.storage/rm *

Thanks for your patience and support flamingm0e :slight_smile:

1 Like