Upgrade to 0.90 failed - how to troubleshoot?

Hey all,

Upgrades have been working perfectly on hassio but I seem to be stuck on 0.88.1. Trying to upgrade to 0.90 just fails and rolls back.

19-03-22 09:49:52 INFO (SyncWorker_3) [hassio.docker.homeassistant] Start homeassistant homeassistant/raspberrypi3-homeassistant with version 0.90.0
19-03-22 09:59:55 WARNING (MainThread) [hassio.homeassistant] Don't wait anymore of Home Assistant startup!
19-03-22 09:59:55 CRITICAL (MainThread) [hassio.homeassistant] HomeAssistant update fails -> rollback!

Any ideas where to start troubleshooting this? where can I find more logs?

Many thanks.

Should add I’m running HassOS 2.8

Same issue. Hass.io Supervisor v150

Look at HA changelog and make needed changes to your configuration.
You will need to check all changes made from 88 to 90.

Likely there is component in your configuration that has changed and you have not made changes.

Also, be aware that api_password is deprecated in 90 so that may be a good starting point if you still use that.

Why not 0.90.1 that was released yesterday?

Thanks @tmjpugh - it was the authentication providers piece that was killing it.

In the end I SSH’ed in to HassOS, caught the logs whilst it was trying to start 0.90 and saw the errors there. Fixed the config file for api_password and trusted_networks and then was able to complete an upgrade.

@anon34565116 - It seems to take a day or so for releases to filter through to hassOS. I’ve just upgraded to 0.90.1 now.

1 Like

I wish there were a way to see those logs without SSH’ing into the OS underling hass.io.

Some people enable Samba so they can mount the config directory and view the log on their desktop.

Thank you for the tip! I ended up troubleshooting using the ssh Hass.io add-on I set up awhile back.

For anyone else who finds this thread, I fixed things by commenting out the api_password entry in the http section, upgrading, then moving the api_password config to the auth_providers section: https://www.home-assistant.io/docs/authentication/providers/#legacy-api-password. NOTE: I was able to safely comment out the api_password – before doing so make sure you won’t lock yourself out of HA!

Also, after the failed upgrade from 0.89.x, all of my automations were turned off…had to go through and turn them back on.


I am having the same issues and tried to do upgrade from SSH which is said “ok” at then end and nothing. I am still sitting at 89. What did you configure in the config to make it work?

see @MrMagic above post

Ah thanks I did not see that part.

Noob question: how/where do I find the logs when SSH’ed to Hassio?
I am trying to upgrade from 0.89 to 0.92 without luck.
Will try the api_password later today.