Upgrade to 12.3 and can't connect with HA App

Running HA on RPi5 as a server, connecting with HA App on Macbook OS or on iOS. Connected a monitor to see any error messages and get: Failed to start Network Manager Wait Online. See systemctl status Network Manager Wait Online for details.
When the banner page appears there is a message: Waiting for the Home Assistant CLI to be ready
[171.076502] CIFS: VFS: Error connecting to socket. Aborting operation
[171.076522] CIFS:VFS: cifs-mount failed w/return code = -101
Starting the HA Client on my Macbook I get message: Could not connect to server
NSURL Error Domain -1004
Back on the Pi I ran a core check with this result:
Error: Can’t execute command: 500 Server Error for http+docker://localhost/v1.44/images/create?tag=latest&from Image=ghcr.io% 2Fhome-assistant%2Fraspberrypi5-64-homeassistant: Internal Server Error (“Get “https://ghcr.io/v2/”: dial tcp: lookup ghcr.io: Temporary failure in name resolution”)
I tried changing the boot-slot back to version 12.2 and rebooted but no luck!!!

Help anyone.

I have fallen back to 12.2 and restored from a backup at that level, all looks good now.

Yes, 12.3 seems to have issues. Lots of threads in this forum reporting problems. I had to back out too. This is the first time I’ve seen this. OS updates have always been seamless for me; something to do when I had a few minutes to spare. Never again! Now I’ll block out a day for recovery before I’ll try another OS update.

Issues with 12.3 can be found here: Issues · home-assistant/operating-system · GitHub.

It might help to provide details to an existing GitHub issue or log a new issue.